Jump to content
  • Sign Up

Troublesome Skyscales not unlocked at reset


Recommended Posts

I have had the same problem 2 days in a row after completing Troublesome Skyscales (and talking to Gorrik, if I speak to him now he just says he has nothing for me and I should check back later). It still says to wait until reset for Riding Skyscales to unlock.

I think this is due to my mailbox being full when I logged in (I had been sent multiple mails) and so it won't deliver the mail to start the next step. Unfortunately I can't stop people sending me multiple mails so it seems I may be stuck at this point for quite some time. I have re-logged, tried multiple characters and been to multiple zones - still no way to progress.

Link to comment
Share on other sites

It shouldn't matter what character considering its an account wide achievement - or at least it should specify!! I fed my Skyscale on my necromancer but did my story on another character entirely. Logging on to the one who did the story eventually launched the mail, but that's not mentioned anywhere as a requirement.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...