Jump to content
  • Sign Up

Game is not visible in window mode (even after reinstall) and crashes regularly


Recommended Posts

Since last night I can only play GW in full screen mode and when I switch to windowed mode (alt+enter or through the settings) it minimizes or rather becomes invisible. I can still hear the sound but there is no image. I can use alt+enter again to go into full screen and it works again. This would be fine if it wouldn't crash at an alarming rate.What I did so far:Submitted the crash log to Arenanet (forgot to copy it...)Updated my graphics driverTried to repair GW (got stuck and didn't respond)Uninstalled and currently reinstalling the game

As the progress hit playable I couldn't resist and started it. The problem is still present.Any suggestions?

Link to comment
Share on other sites

@Nokomis.5076 said:Try holding your Windows- and Shift-key, then use the Left/Right key to see, if it somehow switched onto another (invisible) display

This kinda worked. Which is weird because I don't have another screen or even an HDMI attached to the GPU.At least the game poped up in the left corner of the screen. Only the upper window border was visible and I was able to enlargen it to the desired resolution. Still feels as if the performance is worse than before.

@Ashantara.8731 said:

@Nemecrosius.8634 said:Since last night I can only play GW in full screen mode and when I switch to windowed mode (alt+enter or through the settings) it minimizes or rather becomes invisible.

Are you using any tools that are adding an overlay to the game? Like Discord, for instance? Try deactivating those overlays.

I am using Discord but as of the time of playing I was not running it. A recent update seemed to have activated the overlay function again so I turned it off.

Link to comment
Share on other sites

@Nemecrosius.8634 said:

@Ashantara.8731 said:Are you using any tools that are adding an overlay to the game? Like Discord, for instance? Try deactivating those overlays.I am using Discord but as of the time of playing I was not running it. A recent update seemed to have activated the overlay function again so I turned it off.

And that solved the issue, I take it?

Edit: I don't have Discord, but I think you don't need to have the main program running for the overlay to be active. I believe Discord has it running as a separate task in the background? It must be some overlay causing the issue or else you would not be able to run it in fullscreen mode (if the window was on the wrong, non-existend second screen the game would run there when you select fullscreen).

Link to comment
Share on other sites

@Ashantara.8731 said:

@Ashantara.8731 said:Are you using any tools that are adding an overlay to the game? Like Discord, for instance? Try deactivating those overlays.I am using Discord but as of the time of playing I was not running it. A recent update seemed to have activated the overlay function again so I turned it off.

And that solved the issue, I take it?

Edit: I don't have Discord, but I think you don't need to have the main program running for the overlay to be active. I believe Discord has it running as a separate task in the background? It must be
some
overlay causing the issue or else you would not be able to run it in fullscreen mode (if the window
was
on the wrong, non-existend second screen the game would run
there
when you select fullscreen).

I tested it a couple of times now and it seems to be working fine. Even when Discord is running. The amount of crashes also reduced. I am not a Discord pro but due to the constant updates and automatic changes to the user settings, I wouldn't be surprised if it truely was the source of the issue.

Thanks to both of you for your help! :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...