Jump to content
  • Sign Up

Game shows only cursor after update

Recommended Posts

After the recent small bugfix, I see the hand cursor used to rotate the character in character selection and hear the character selection screen music after running the game and nothing else. If I press Enter, I don't hear the button "clink"

I restarted my PC and deleted my damage metrics overlay, still nothing. I tried Alt+Enter in case it were a fullscreen issue, but nothing happened either. I've got a very slow connection so please don't tell me to reinstall the game, it will take ages.

Running Windows 10 Pro.

Link to comment
Share on other sites

I tried repairing the client, no dice.

I also tried clearing the cache in the %temp% folder and it did nothing.

I think I found the solution, or at least the cause.

However, while troubleshooting, I forgot a very basic step: close my other background programs, like RivaTuner, ASUS GPU Tweak and Logitech Gaming Software. I closed all of them and the game ran fine. I singled the problem out to RivaTuner Statistics Server, I use it to cap my FPS. I was able to recreate the problem, if I have RivaTuner running, the game won't show anything except the cursor. If I close it, it's fine. Since I rarely (or rather, almost never) reach my 162 FPS cap with GW2, it's not a huge deal.

This app has never caused any issues in the past either with GW2 or other games, but I did get a large-ish Windows update recently, so something might be bickering after the update.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...