Jump to content
  • Sign Up

My game crashes at least once a day on brand new computer :(


Recommended Posts

I got a brand new computer since friday and unfortunately, something is causing the game to crash.

What happens is: one moment I am in game(doesn't matter if the map is empty or full it happened on all occasions) and suddenly the screen goes black and all I see is the arrow of my mouse, and I still hear the music of the game.

When I press the windows key and ctrl+alt+del the gw client shows up as running and I don't get any error messages, none in game and none in the running tasks window. When I ask others about my in-game status I'm told I'm offline. Hence why I use the word crash, but please let me know if there is a different word for this. :)

Anyway, I tried:repairing the gameuninstalling and reinstalling the game.lowering my settings

I can rule out:My internet, because more people in my household play the game in the same room as me and they don't get crashes.

My specs:processor: intel® core i7-8700 CPU @ 3.20GHz 3.19GhzRAM: 16GBsystem: 64bit x 64 processorActivated version of windows 10

I use geforce experience to keep my driver up to date, it informs me I have GeForce GTX 1660 Ti with the latest driver: version 436.02 releasedate: 08/20/2019

My settings in game:YjySP1i.jpg

Windows specs:version: 1903 windows 10 home

Please help!

Link to post
Share on other sites
  • Replies 72
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Things that won't solve the problem: Change ISP Change router settings Get a new router DDU all driver and reinstall drivers Updated drivers Get a new graphic card Windows 10 update Update Windows dr

Do you happen to be using Avast as your antivirus? The reason I ask is because I have a 1660 Ti also and few months ago I was having the same problem. Through my trouble shooting I uninstalled Avast and went back to Windows Defender and the problem went away. So I think somehow Avast was causing my problem. I have not tried going back to Avast to see if the problem came back though. If not you could also try rolling back your driver to an older version.

Link to post
Share on other sites

Thanks for sharing, much appreciated and I will keep it in mind :) It's a new computer and I haven't installed anything on it besides guild wars and sims 4, so the only antivirus it has is the windows defender it came with.

Windows defender HAS given me some trouble with the origin gameclient by shutting down internet entirely until i closed the origin app, but that was solved by turning the firewall off while it was downloading a game and then turning it back on again.

Link to post
Share on other sites

I have the same exact problem since november 2018 and I have not received any help from Arenanet. Someone in reddit (2017) said the problem was caused by internet inestabilities, but you said you have more than one person playing at the same time and you are the only one crashing... then I dunno whats going on. Nowadays I'm still looking for a solution. Ill help you copy/paste all info I can find.

Link to post
Share on other sites

Things that won't solve the problem:

  • Change ISP
  • Change router settings
  • Get a new router
  • DDU all driver and reinstall drivers
  • Updated drivers
  • Get a new graphic card
  • Windows 10 update
  • Update Windows drivers
  • Reinstall the game
  • Delete .dat and re-patched
  • Use -repair on gw2.exe
  • Use -windowed on gw2.exe
  • Connect through VPN
  • Open up the PC and give a vacuum blow
  • Update and get more RAM
  • Disable fire wall
  • Get a new anti virus
  • Port forwarding for ports 80 443 6112 and 6600
  • Get new processor

Things for future testing:

  • Use -clientport 80 or -clientport 443
  • Get support for Arenanet
  • Sad 1
Link to post
Share on other sites

to inculpatus cedo.9234Thank you for the suggestion! I will definitely do that if the problem persists.

to popocatl.2649Oh boy :( that is a mighty long list, I can imagine how frustrating it must be to have tried all those things and still have the problem. Is there a tutorial somewhere online on how to use different client ports I can follow? If there is then I can check with my housemates if they use the same ports or if I'm somehow on a different one than they are.

I was in the middle of my story and it just crashed again :( which is especially frustrating.Thank you so much for responding, all this information is helpful. I was almost going to consider returning the pc to the store and have its componants changed. It would be discouraging to do that without avail.

The only things I can come up with about my computer that are different from my housemates is BIOS firmware, but I don't understand a lot about computers so I'm just guessing in the dark here, but it's good to look for differences between my computer and those of the people who don't have to problem, and to compare computers with people like you who have the same issues. :) It would be pretty amazing if we could help each other!

Link to post
Share on other sites

@inuraichi.6178 said:to inculpatus cedo.9234Thank you for the suggestion! I will definitely do that if the problem persists.

to popocatl.2649Oh boy :( that is a mighty long list, I can imagine how frustrating it must be to have tried all those things and still have the problem. Is there a tutorial somewhere online on how to use different client ports I can follow? If there is then I can check with my housemates if they use the same ports or if I'm somehow on a different one than they are.

I was in the middle of my story and it just crashed again :( which is especially frustrating.Thank you so much for responding, all this information is helpful. I was almost going to consider returning the pc to the store and have its componants changed. It would be discouraging to do that without avail.

The only things I can come up with about my computer that are different from my housemates is BIOS firmware, but I don't understand a lot about computers so I'm just guessing in the dark here, but it's good to look for differences between my computer and those of the people who don't have to problem, and to compare computers with people like you who have the same issues. :) It would be pretty amazing if we could help each other!

Yes, you can find instructions in the Knowledge Base, accessed via the 'Support' link above/below.

Link to post
Share on other sites

@"inuraichi.6178" said:to inculpatus cedo.9234Thank you for the suggestion! I will definitely do that if the problem persists.

to popocatl.2649Oh boy :( that is a mighty long list, I can imagine how frustrating it must be to have tried all those things and still have the problem. Is there a tutorial somewhere online on how to use different client ports I can follow? If there is then I can check with my housemates if they use the same ports or if I'm somehow on a different one than they are.

I was in the middle of my story and it just crashed again :( which is especially frustrating.Thank you so much for responding, all this information is helpful. I was almost going to consider returning the pc to the store and have its componants changed. It would be discouraging to do that without avail.

The only things I can come up with about my computer that are different from my housemates is BIOS firmware, but I don't understand a lot about computers so I'm just guessing in the dark here, but it's good to look for differences between my computer and those of the people who don't have to problem, and to compare computers with people like you who have the same issues. :) It would be pretty amazing if we could help each other!

I'm sure is the gw2 optimization cuz I've changed selled my laptop and then bought my actual PC Gamer and still have the problem. Oh, btw, this is the link for what you asked for:https://wiki.guildwars2.com/wiki/Command_line_arguments

Link to post
Share on other sites

to Aaralyna.3104 I'm not sure what you mean, my computer is new so there are no updates that I'm aware of as it came with the latest windows version.

to Inculpatus cedo.9234 and Popocatl.2649 Thank you very much! Unfortunately client 80 and 443 replicated the crash in under five minutes which is impressive. I also tried clientport 6112 but the crash also happens there :(

I tried playing with my windows defender wifrewall turned off (all three of em) but the crash still happened. I'm going to contact arenanet about the issue, hopefully they can help. I'm open to more suggestions, in fact I would very much appreciate it. Got to keep hitting this problem until it's tackled!

Link to post
Share on other sites

I think op and I are encountering the exact same issue. This may be a server desync issue with the game client (not sure why yet). I'm waiting for the Tuesday update to see if it's a packet loss issue resulting from the recent game build, otherwise I'm going to reformat my ssd to eliminate the possibility of corrupted files or program overlap.

Link to post
Share on other sites

to Inculpatus cedo.9234 None, all I have is geforce experience and that only runs if I start it up first.

@gatsu.2813 Thanks for replying, that's very interesting, but it's weird that my housemates don't have the problem and we do. I opened a ticket with a link to this thread and a copy paste of the ArenaNet diagnostic I ran. Posted it 11 hours ago, and it sais last activity 4 hours ago, not sure if me looking to check for replies counts for activity, but if not they are looking into it at least. Thank you for replying, hopefully we'll get to the bottom of this. Did you also get a close wait at TCP 192.168.178.15:49247 23.202.229.66:443 when running a -diag?

I'm not sure if that's enough to warrant a crash, but it might be a clue to identify the problem.

Link to post
Share on other sites

Yes I had close wait popping up in my networkdiag file.

TCP 192.168.1.4:49800 23.45.231.50:80 CLOSE_WAITTCP 192.168.1.4:49801 23.45.231.50:80 CLOSE_WAITTCP 192.168.1.4:49803 23.45.231.50:80 CLOSE_WAITTCP 192.168.1.4:49804 23.45.231.50:80 CLOSE_WAITTCP 192.168.1.4:49805 23.45.229.36:443 CLOSE_WAITTCP 192.168.1.4:49807 23.45.231.50:80 CLOSE_WAITTCP 192.168.1.4:49808 23.45.231.50:80 CLOSE_WAIT

Link to post
Share on other sites

Just an update of my situation. Thanks to working with anet support, we have identified that it is possibly a network connection issue of the wireless Netgear router. At the moment I am directly connected to the Comcast modem via ethernet and the crashes have stopped in the past 24 hours. Anet says I should play another day to see if a crash can still happen. If it is the router, I will set it to factory default, otherwise gonna buy a new one.

Link to post
Share on other sites

@gatsu.2813 said:Just an update of my situation. Thanks to working with anet support, we have identified that it is possibly a network connection issue of the wireless Netgear router. At the moment I am directly connected to the Comcast modem via ethernet and the crashes have stopped in the past 24 hours. Anet says I should play another day to see if a crash can still happen. If it is the router, I will set it to factory default, otherwise gonna buy a new one.

Yeah for peeps in the future if you are on wireless always try a wired ethernet connection as drops like this leading to crashes in gaming happen often enough that it should be the first thing to check out

Link to post
Share on other sites

Little update on the situation:

The latest patch eliminated the problem for PVE, PVP and WVW gameplay, but me and the GM's are still troubleshooting to find the problem with why it's still happening in instances.

Things tried so far that didn't work include:Playing in windowed mode. (to rule out settings)Disabling all non-windows background applications.DNS flush and winsock reset.

Link to post
Share on other sites

@"Popocatl.2649" said:Things that won't solve the problem:

  • Change ISP
  • Change router settings
  • Get a new router
  • DDU all driver and reinstall drivers
  • Updated drivers
  • Get a new graphic card
  • Windows 10 update
  • Update Windows drivers
  • Reinstall the game
  • Delete .dat and re-patched
  • Use -repair on gw2.exe
  • Use -windowed on gw2.exe
  • Connect through VPN
  • Open up the PC and give a vacuum blow
  • Update and get more RAM
  • Disable fire wall
  • Get a new anti virus
  • Get new processor

Things for future testing:

  • Use -clientport 80 or -clientport 443
  • Get support for Arenanet
  • Use -clientport 80 (doesn't work)
  • Use clientport 443 (doesn't work)
  • Start the game as admin (doesn't work)
Link to post
Share on other sites
  • 2 weeks later...

shirley the ppl that built ur puter should be giving u technical support, so using hardwired now, do ppl really use wifi lel sry, pre built win 10 , shivers.... just sounds like a game dc nothing over complicated, when gw2 dc's it does that if u were losing a wifi connection then that could of been ur cause, its a process of elimination weakest link first.

Link to post
Share on other sites

Okay, as it turns out the latest patch only temporarily solved the issue for regular and PVE and PVW. The past two weeks I've been going back and forth with GM's over how to eliminate the problem again. They had me run several ping plotter and GPUZ tests to pinpoint when the crashes keep happening.

We tried uninstalling-reinstalling guildwars.Repaired missing or corrupt system files with Microsoft's System File Checker toolUse google DNS settings:Google DNSPrimary DNS: 8.8.8.8Secondary DNS: 8.8.4.4Reset my BIOS

All these things proved ineffective. They asked me to contact my ISP, which I did over the phone. My ISP is Ziggo and they put our router through a different path, but unfortunately that didn't solve the issue. I also think it remains odd that this happens to me and not my housemates who use the same wireless internet as me.

I even forwarded my emails to the store I bought the computer from since they provide technical support for their customers, and they informed me this is a long known bug that is related to Guild Wars 2 the game, and even linked to these two sources that reported a similar issue:

https://www.reddit.com/r/Guildwars2/comments/711odk/black_screen_but_you_can_still_see_the_cursor_and/https://en-forum.guildwars2.com/discussion/8138/fixed-black-screen-with-cursor-bug

And now I'm copy pasting my ticket correspondence over to a google doc so I can send it to my ISP customer support, who annoyingly enough don't have an email address to mail to but rather a "contact form" type of deal on their website, meaning I can't just press the forward button on my hotmail and send it to them. Straight up copy-pasting it over in the little box would probably be a bit much, not to mention cluttered and difficult for them to go through.. Sooooo great, just more and more time going into me troubleshooting this game, I've been really patient the first month, but now I'm getting frustrated.

Link to post
Share on other sites

I'm not going to do those things without knowing what it is I am doing.

What does the appdata folder do? And why would removing it help my problem?I have nothing of Nahimic.DVR game bar was already disabled.

The GM said the issue was packet loss which causes the connection to the game client to break and to inform with my ISP. I contacted my ISP about it, but they haven't gotten back to me yet, I will call them tomorrow to ask what's taking so long.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...