Jump to content
  • Sign Up

[BUG REPORT] New Decoration Failure


Recommended Posts

So the new decoration tokens do not seem to work at all.

Bought the heliplatform and charr tank, but any attempt to consume the items results in the animation for cosuming them, but they remain in inventory.

The decoration merchant in the guild hall does not have these items available like they do with some other token decos either.

At the moment, I've tried double clicking in the guild hall, double clicking in Grothmar Valley, double clicking on multiple toons (including my master scribe) and no joy from these.

Also tried repping many different guilds from level 0 to level 69 and still no go.

Anyone else have any experience getting these to work?

Link to post
Share on other sites
  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

When I bought them oder the last two weeks, there was no problem, they didn't even enter my inventory and got immediately deposited in the decoration storage of the guild I was currently representing. When I bought two tanks today, I ran into the problem Krigjeger described. I'd hazard a guess and say it's been broken by the patch on tuesday.

Link to post
Share on other sites

Yeah, they broke them. Had no problem with the Monument and a Helipad last week. Bought a Charr Tank yesterday evening after reset, and I couldn't consume it. Tried it in several guilds, put it on a 400 Scribe (LOL) and nothing worked. I guess they'll fix it when they fix it. I did put in a ticket asking for my Hatched Chilies back!

Link to post
Share on other sites

Oh good, I thought it was a problem only for me, maybe because my guild is only lv4. I bought the Branded Devourer Monument and the Charr Tank together: the first worked, the second is still in my inventory, despite the animation when I double-click on it.

Link to post
Share on other sites

Glad it wasn't just me all along :) Here's hoping that its a minor switch that they flick back on with tomorrows patch/update.

And rather than create yet another ranting post elsewhere I'll say here that I sure wish there was someone at Anet who actually could just pop through this forum once in a while and at least acknowledge things that are clearly broken and will be investigated. Just a quick "sorry! we busted something" would be nice once in a while. Could have sworn they used to do this occassionally :p

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...