Jump to content
  • Sign Up

Storyline Disconnects - [Merged]


Recommended Posts

Posted (edited)

I noticed one post mentioned it but has anyone else been able to fix this using a vpn? I plan on testing it out myself once the game finishes downloading but I'd hate to get invested in the game again due to a few flukes making me think that the issue is fixed to just get screwed later on. 

 

No other game has quite frustrated me the way GW2 has with this issue. I was super into the game, the story. Then out of nowhere towards the end of the 1-80 story I start encountering this issue that only seemed to get worse the farther in I got in the story line. I did my best to not only try and fix this issue but to even power on through it, replaying stories multiple times until I got lucky but eventually I just got sick of it and quit for many months only rechecking this thread once in awhile because I still really wish to play but I see no point if such a decent chunk of the game is locked out for me basically. 

Edited by Vogga.2465
Link to post
Share on other sites
  • Replies 651
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yep, people do suffer from DCs but it's over all a fairly small percentage of the playerbase. I'm sure Anet has tried to fix this but can't always repeat it and that's the problem. I've done e

And, I am done with GW2.    Having completed a Story step, on exiting I was disconnected on entering the main game world.  On (immediately, still logged in and at character select on getting

I keep getting DC'ed on around 20% of main quests, and never anywhere else. This is so frustrating.

Some players have, indeed, had luck using a VPN.  It's one of the suggested solutions in the official Knowledge Base.

Do make sure it takes a different path to the game server, though.  Taking the same path as without will elicit the same result.  (You can use a program like PingPlotter to trace your route [google how to trace/ping AWS servers].)

 

Good luck. 

Link to post
Share on other sites

Bumping the thread as anet did nothing to fix the bug and yes - this is a bug in their application - nothing to do with our systems or how we connect to the internet. If a client looses the connection with the server, it should simply reconnect - that's how all TCP applications work.

Right now we have to complete "Hidden Arcana" story to get the new achievement. This is one the longest story missions and I already got disconnected twice at the same moment.

Oh, and don't bother contacting support - they will spam you with some stupid, useless tasks like getting hijack logs (srsly who uses this in 2021?) or getting tracert stats.

  • Like 1
Link to post
Share on other sites
On 5/24/2021 at 6:36 PM, MrChips.8147 said:

This is not our problem, its a GAME issue that needs to be fixed. 

Been playing since pre-launch and I've been having this problem seemingly at random since around 4 years ago and it's progressively gotten worse. None of the workarounds even work well and it's 100% an issue with the game. The devs need to stop being lazy and actually fix the video game they made instead of telling players it's our problem to deal with not theirs.

  • Like 3
Link to post
Share on other sites

to be fair they really need to put check points into missions especially the really long ones, either that or take out what ever auto disconnect when idle mechanic they have the cause the server to think you AFK when you are just reading a CS or standing still listening to people talking to each other.

  • Like 1
Link to post
Share on other sites

I too am having the same issue after story cutscenes. Right after I see my character with a "film" icon over their head and then I disconnect and get kicked out to the character select screen. I didn't have this issue until around the "Battle of Claw Island" story missions. I have tried the client port 443 trick, as well as running a YouTube video in the background while playing and also hitting movement/skill keys during cutscenes and these have helped me successfully finish a few story instances but now they don't seem to be working on the current story step I'm on. I have also reached out to support and they have gotten me to try several things such as run programs like HijackThis, run as admin, compatibility mode and even creating a new windows account but I am 100% certain that there is nothing wrong with my computer as I don't have any issues with any other game. I also went through the traceroute procedure that they have on their website and in the results it shows that everything on my side is fine and that the packet loss is coming from their game servers. The fact that this issue has been going on for several years is ridiculous. I am considering dropping the game because its just not worth running through the same instances multiple times hoping that it doesn't crash. You shouldn't have to use workarounds either just to get the game to work. Fix your game. 

  • Like 2
Link to post
Share on other sites

Just updating hoping to possibly help some players out. When I originally started getting disconnected around "Battle of Claw Island", I started doing the following...

- Clientport 443 added to target name in properties

- Have a long YouTube video running in the background while playing

- Continuously press movement and skill keys during cutscenes.

Doing these 3 things helped me get through several story missions up until recently when I started getting disconnected again in the exact same spot after an unskippable cutscene. 

 

What I am doing now is only 2 things and I have now successfully completed the story mission I was stuck on for a couple days. This is all still taking place during the core lv80 story missions by the way.

 

What I did differently is I switched clientport 443 to 80. I read on reddit I believe that some story instances seem to work better with certain clientports. So if I have a disconnect again, I will either switch back to 443 or try a different clientport to see if that fixes it.

 

The other thing I am doing is I cleared the game cash and I am actually thinking of doing this every time I launch the game just as a safety measure.

 

Hopefully this helps some players out.

Link to post
Share on other sites
  • 2 weeks later...

Dear Anet, this problem has been going on for years and yet you do nothing to fix it. It is NOT on my end; since I started playing this game I now use a different computer, with a different router, on a different Internet provider. The old connection was a phone line, the new one is a fibre connector AND IT STILL HAPPENS.

 

It is ALWAYS the final cut scene of a mission. movement keys, power keys, changing ports. none of it fixes the problem. Why can't you just have the client ping the server during the cut scenes to keep it alive?!

 

No more money from me, I'm done putting up with it.

  • Like 1
Link to post
Share on other sites

I am having a constant recurring crash (error code 7:11:3:202:101) during the last scripted scene at the end of the Crystal Dragon instance, always at the same spot. I have played this on a previous character a while ago and never had this problem. I tried repairing the client, which did nothing. This is stupidly frustrating, especially since it's a long instance and you have to go back and replay half of it just to get back to that spot. Serious Anet, why is this crap with crashes and disconnects during instanced story missions still a thing?

  • Like 1
Link to post
Share on other sites

This has probably been repeated hundreds of times but i'm getting disconnected during story missions often. Can Anet please just fix it so that you can just pick up the story from where you left off. This is infuriating lol, Second time i've been disconnected at the end of a story mission. Almost threw my pc out the window.

  • Like 1
Link to post
Share on other sites

plenty of things to try.

Have you tried repairing client so its not somthing thats corrupted?

https://help.guildwars2.com/hc/en-us/articles/201863008-Repairing-the-Game-Client

 

You can try spaming skills like for example nr 1 over and over while cinematic plays.

 

Try deleting the gw2 config and cache.

 

Try useing a vpn like for example  WTFast and see if that fixes it.

 

What is your streaming option under option?

Try another one there and see if that helps.

 

Link to post
Share on other sites

For the past few weeks I have been running through the personal story on a new character. It seems like every couple of chapter sections, I disconnect from the game after (or maybe during) the dialogue cutscenes. When the dialogue is over and it goes back to my character I still have the movie reel symbol over my head, can't move or do anything, and a minute later the game says it can't connect.

 

Re-running the section has usually worked with no problem, but now that I've made it to Orr, repeating the content I've just gone through can be a real pain in the rear.

 

I have checked my internet connection and so far have not found anything to explain the disconnects. Anyone know of a way to test the connection to the game servers or maybe find a log that can help with troubleshooting?

 

Thanks.

Link to post
Share on other sites
Posted (edited)

If you use Windows 10 , you have to disable windows virus protection or this game will disconnect you from story missions. This completely fixed my disconnect issues.

 

 The bad part is windows 10 will only let you disable it temporarily, so you have to check it every few days to make sure it stays disabled.

Edited by RippyToucan.2083
Link to post
Share on other sites

Thanks. Looks like the last dev response in there was almost exactly 3 years ago. Do you know whether they have made any mention of it since? As some have noted in the thread, it does seem odd that the disconnects happen during cutscenes. Like the client is deciding the player is inactive and closes the connection while the game is still running.

 

Following links relating to changing the port the game connects on, I see there are ways to turn on logging. I wonder if that might shed additional light.

 

Still going through the 20+ pages of the thread, but at least I know this is far from an isolated problem.

  • Like 1
Link to post
Share on other sites
1 hour ago, RippyToucan.2083 said:

If you use Windows 10 , you have to disable windows virus protection or this game will disconnect you from story missions. This completely fixed my disconnect issues.

 

 The bad part is windows 10 will only let you disable it temporarily, so you have to check it every few days to make sure it stays disabled.

Even if this seemed to work for you, I would caution that leaving your computer security turned off is not usually the best plan.

 

I have been on Win10 for years now and have only had the cutscene disconnect problem for a couple of weeks now. this is not to say Microsoft couldn't have changed something in the virus protection that would affect the game, but I'd need to see more information about what is happening before reaching that conclusion.

 

I am still going through this long thread, hoping there is some manner of logging I can use to get that information. Whether through the client itself or through connectivity tests. Either way, it does seem to be connected to cutscenes for the most part. Have the devs said anything more on this in the past 3 years?

Link to post
Share on other sites

I cannot describe how frustrating this is. It happens to me a lot - unless I'm in a party with someone (who is either in the instance or just out in the world) I get booted. The other day I got so frustrated trying to complete LWS2 achievements that I 'leeched' a Silverwastes Squad, hoping no one would notice I wasn't in map and participating, just so I would be 'partied up' and the game wouldn't forget I was online mid-instance. They did notice, before I finished an instance, and of course - it booted me out and I lost credit for the achievement I'd worked for an hour. How is this fair to people who have to play solo 90% of the time??

 

Just now - I literally spent 45mins trying to complete LWS2 Seeds of Truth - No Refuge with the Challenge Mote, finally beat the boss without dying and I get to the Wynne/Faolin conversation at the end and it boots me out. Again. Came on here to vent (as this has happened to me for years) - to find that this thread is 22 pages and has been unresolved for years. 

 

What's more frustrating - I'm not brilliant at the game, so I have to work hard for some of these achievements. I have limited play-time as I'm a mum to two kids under 3. I shouldn't get excited after finally doing something I was finding incredibly difficult to then be left heartbroken less than a minute later when I can tell the instance has stalled and is about to boot me out of the game again, wishing I wasn't playing alone.

 

It really really really sucks.

  • Like 3
Link to post
Share on other sites
10 minutes ago, lindydrew.9382 said:

I cannot describe how frustrating this is. It happens to me a lot - unless I'm in a party with someone (who is either in the instance or just out in the world) I get booted. The other day I got so frustrated trying to complete LWS2 achievements that I 'leeched' a Silverwastes Squad, hoping no one would notice I wasn't in map and participating, just so I would be 'partied up' and the game wouldn't forget I was online mid-instance. They did notice, before I finished an instance, and of course - it booted me out and I lost credit for the achievement I'd worked for an hour. How is this fair to people who have to play solo 90% of the time??

 

Just now - I literally spent 45mins trying to complete LWS2 Seeds of Truth - No Refuge with the Challenge Mote, finally beat the boss without dying and I get to the Wynne/Faolin conversation at the end and it boots me out. Again. Came on here to vent (as this has happened to me for years) - to find that this thread is 22 pages and has been unresolved for years. 

 

What's more frustrating - I'm not brilliant at the game, so I have to work hard for some of these achievements. I have limited play-time as I'm a mum to two kids under 3. I shouldn't get excited after finally doing something I was finding incredibly difficult to then be left heartbroken less than a minute later when I can tell the instance has stalled and is about to boot me out of the game again, wishing I wasn't playing alone.

 

It really really really sucks.

Have you tried any of the many, many tips/workarounds found in this thread?

There's a lot to choose from, and one (or more) may offer some relief.

 

Good luck. 

Link to post
Share on other sites

I have in the past and am currently trying anything new, but it is genuinely not the point.

 

It is a bug - poor coding - not player error, not my system, not my internet connection (the only things I should really have to manage btw). I shouldn't have to be doing things like using a VPN (which is probably not very inline with the T&Cs anyway) and messing around with switching my virus protection off to play a video game that has had this problem for its entire existence, the best part of a decade now.

 

Again, how is it fair that I have to spend 30 mins to an hour researching rubbish like this when I have little time to play the game in the first place?

 

What is the point in a thread like this if it can get to 22 pages in length and be totally ignored?

  • Like 3
Link to post
Share on other sites

Not totally ignored, as the Dev post(s) indicate.

Since it does not affect all players, and can not be reliably reproduced in QA, it seems there is not a 'one fix fits all' solution.

 

Your choice to try some of the tips...or wait for said solution.

 

Good luck. 

Link to post
Share on other sites
Posted (edited)

I have fought the last battle with Ryland 3 times now.  I get to hear how his mother loathes him every time and then crash, every time.  I can't get past this.  It's the end of the damned thing but I can't get past it.

 

Also, I 100% agree with Lindydrew, this isn't OUR responsibility to try and work around with tips and tricks.  This is a broken game.  I don't even approach caring if it doesn't effect everyone.  Bugs rarely do.  It's still a bug that has existed forever and NEEDS to be fixed.  This has been a problem for ages.  It's unconditionally frustrating and puts a sour taste in my mouth for one.  My experience with this is ALWAYS right after an incredibly long, BORING, fight that gains absolutely nothing by being so drawn out.  It's one mechanic played over and over until I eventually whittle him down enough.  I've done it too much to care enough to actually put effort into it.  It takes longer, but it wasn't fun the first time, why should I try when I literally can't lose.  Why does this even have to exist?

Edited by Kal Spiro.9745
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...