Jump to content
  • Sign Up

Achievement: Glorify the golden heart - Dominant Royal Onyx not obtained


Recommended Posts

I tried the glorify the golden heart achievement today but got stuck at the earth orb. I had everything in my inventory that was necessary (Amalgamated gemstone). I can interact with the orb but can't get the dominant royal onyx (https://wiki.guildwars2.com/wiki/Dominant_Royal_Onyx). I got all the other gems tho at the other orbs. I tried to interact with other orbs, tried two different characters (both with amalgamated gemstones), a relog, different positions in front of the orb but nothing helped.I tried with a group and without. I put my amalgamated back into the bank and out again. I put the amalgamated in different bags of my inventory. I tried it with my thief and with my necromancer infight and out fight. I killed all the earth-elementals beneath the orb. I don't know what I can do to additionally.Now I'm stuck and can't get the funerary armor chest and subsequent the achievement.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...