Jump to content
  • Sign Up

Hero Challenges at Auric Basin don't get checked off, no reward

Recommended Posts

I wanted to do a (solo) HP run at Auric Basin yesterday, but did not get a hero point reward, nor did the icon change to mark an earned hero point. Today I tried again, still the same. It only seems to happen at Auric Basin though. To test if all HC's are bugged, I tried a few different locations:

Crystal desert: Amnoon Southern Outskirts - Icon changed, hp rewardedVerdant Brink: Near Treacherous Path waypoint - Icon changed, hp rewardedAuric Basin: Exalted Overlook - NothingAuric Basin: Tarnished Treetop (toxic bacon challenge) - NothingAuric Basin: Burnisher Quarry - Nothing

It's weird, because when trying again it says I already did it.Example image of Exalted Overlook:https://imgur.com/a/ZJwgSPHAs you can see, the displayed icon remains as if I did not interact with the HC yet.

Please let me know if additional information or testing is required.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...