Jump to content
  • Sign Up

Forging Steel Tank Bug


Recommended Posts

I just did the Forging Steel Story in squad mode.During the end boss fight I got downed while entering the tank, guess I had some burning stacks on me or sth, dunno. I had the usual downstate skills (while moving with the tank) and rezzed myself with considerable help from my comrades. Upon reviving I stood atop the tank and couldn't move. I had my normal weapon skills (bers war double axe) and could activate them but not move myself. No jumping or evading worked, for the rest of that end boss fight I could do nothing.After the fight I tried to use the waypoint, but after the according mini-loading screen I still stood atop the tank.Next thing I tried was relogging. After that I was in the eye of the north hub and, being still in my squad, I reentered the cleared instance.I could open the end chests (at least I got the opening animation) but I got no loot.About an hour of fighting and events and stuff - for nothing :/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...