Jump to content
  • Sign Up

Stuck on loading screens at random

Recommended Posts

Been having this problem for a few months now. I can play all day and this problem won't happen but occasionally its strikes. Doesn't seem to be linked to any particular map. The problem is that I will waypoint somewhere and end up being stuck on the loading screen. However my character has properly loaded into the map, I can hear my surroundings and even move around as confirmed by a few friends.

Is there a fix to this problem? I tried googling this problem and found one person with a similar problem that actually got a response back in 2012. It was suggested that I create a repair version of gw2.exe to fix it. Tried this and literally the first time I tried to waypoint after using this method I got the loading screen bug, which I guess was convenient since I wanted to know if this worked or not asap lol. So clearly that wasn't the fix, does anyone else have any other ideas on how I could get this problem fixed?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...