Jump to content
  • Sign Up

Your servers are getting laggy on more maps - [Merged]


Recommended Posts

Please investigate your servers as this game is not playable with constant lag spikes. LS4 maps are now starting to lag on NA. This is an action game with active dodging and mechanics like overheat. The game does not function and is NOT playable with lag spikes.

No, it's not my connection, if I ask in map chat, people on different ISP's all over the earth are getting the same lag in the same zones.

Link to post
Share on other sites
  • Replies 111
  • Created
  • Last Reply

Top Posters In This Topic

@"kumiponi.6047" said:I suspect there are certain people how would be willing to and more than capable of fixing the issues for them, for the small price of getting a temporary access to the source code and server infrastructure. =)

"willing" and "capable" are two pair of shoes. :)

To think to be able to fix something without knowing the background of the systems that need to be fixed is usually not the road to success but the road to more problems.

Link to post
Share on other sites

@Shiyo.3578 said:

@Randulf.7614 said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

No idea. They certainly should have acknowledged it ages ago but they didn’t. The EU has been affected since at least April and they’ve had bug reports since then

Ultimately though, it’s now being investigated

Link to post
Share on other sites

@Shiyo.3578 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

https://en-forum.guildwars2.com/discussion/111982/an-update-on-game-performance-issues

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.

Link to post
Share on other sites

@Swagger.1459 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.

It's happening to me as well and has been for weeks. Computer is fine and so is my overall connection. GW2 is the only program / game experiencing this issue. Seems to be the case for a lot of other people.

Link to post
Share on other sites

It's starting to concern me now.

Ice Brood Saga Maps were the first to be noticably laggy for me.Now im getting it in PoF maps too and sometimes Core world as well.. it definitely seems to be a problem that is getting worse with time.Bjora Marches has been so laggy for me the last few times i've gone there that I've quit playing on it entirely.

I havent even played the last 2 episodes becuase of the Voice acting and I am very worried at this point that when the Voice acting comes in I won't be able to play them at all because of the lag.

The world boss rush also starts soon and I am worried that is also going to be utterly unplayable as well which is going to really suck.

Link to post
Share on other sites

@Jagblade.4627 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.

It's happening to me as well and has been for weeks. Computer is fine and so is my overall connection. GW2 is the only program / game experiencing this issue. Seems to be the case for a lot of other people.

The route from your PC to a particular game server is not the same. The issue can reside with the servers themselves or with the path that your ISP chose.

Link to post
Share on other sites

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

https://en-forum.guildwars2.com/discussion/111982/an-update-on-game-performance-issues

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.

It's nice that you don't lag and that Anet says they are working on it but for me the lag is getting worse and worse, along with the disconnects. For me, and from the complaints in chat, for others, the lag is bad in WvW and has gotten even worse during the World Boss rush today. It's fine to say check your own computer and isp but when the only place I am getting any lag at all is in GW2, I have to wonder if the fact that they are running a Festival, a WvW event, and a World Boss event, all at the same time, all in the middle of pandemic with many more people than usual staying at home, has anything to do with the current lousy performance of their servers. Heck, during the Admiral Taidha event I couldn't place any of the bombs because once I managed to pick one up, it took sooooo long to place it at the gate. Then I got disconnected in the middle of that battle. So you can apologize for Anet all you want but the game is still becoming unplayable for me.

EDIT: And now I can't even log in to the game anymore: "Guild Wars 2 Has Encountered An Error..."

EDIT 2: After four tries I was able to log back in just in time for the Tequatl battle. This time the lag was in mounting and dismounting. As you may recall, in that battle you spend a lot of time running around back and forth between Tequatl and the various batteries. A mount comes in handy for all that scurrying about unless you are unable to dismount or remount without a looooonnnnggg lag each time. That's it for me today. I'm off to stream some HD movies which I can do just fine without any lag and will try GW2 again after the reset.

Link to post
Share on other sites

@kharmin.7683 said:NA East Coast and had no lag last night in Dragonfall. Spent about 45 minutes on the new map this morning without lag. Just adding this for data.

EU servers today - ran through 8 world boss events, including the Admiral, with no lags. My computer hasn't changed since the horrific lags yesterday, nor has my isp. So please explain to me again why, when Anet decides to run a Festival, a WvW event, and a World Boss event all at the same time, at a moment when far larger than usual numbers of people are staying home around the world, and then I, along with a number of others, get hit with horrible lags, I should blame my computer set up or my isp? Seems pretty obvious that Anet simply wasn't ready for the load that hit their servers and that they scrambled trying to catch up and adjust. I'm glad they did but let's not try to shift the blame for the problem.

P.S. Haven't made it to WvW yet today but I sure hope the lag issues have been resolved there too. WvW has been great fun this week when I've been able to play there. :)

EDIT 1: Spent a considerable amount of time in WvW later in the day. Some solo roaming, some running with a small group, and a big chunk of time in a large zerg. There were no noticeable lags for me, even when our zerg ran into equally large enemy zergs and fighting broke out all over the place. Again, it was the same computer set up and the same isp on my end so clearly the lag problems were on Anet's end and whatever the problems were, they seem to have dealt with them.

Link to post
Share on other sites

@Swagger.1459 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.Excuse me, what?I live in FL on ATT&T, my friend lives in new zealand, my other friend lives in russia, and my 3rd friend I've talked to lives in wisconscin on spectrum. I'm on windows 8.1 and one of my other friends is on W10. We all lag in Bjoras at the same time when it's lagging.

I'm a computer science major with a RHCE cert, I'm pretty sure I understand basic networking issues.It's NOT me.

Link to post
Share on other sites

@Swagger.1459 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.

Hmm I appreciate them looking into it, but that post also mentioned peoples latency and other problems that are user related. The main problem for most is however the server performance..

Link to post
Share on other sites

It's a massive problem for me, yeah. I rarely complain about creative decisions ANet makes but this server situation is close to a make-or-break issue for me. You can't really be considering another expansion without fixing servers first, can you? Cause that is just plain insane.

Link to post
Share on other sites

@Shiyo.3578 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.Excuse me, what?I live in FL on ATT&T, my friend lives in new zealand, my other friend lives in russia, and my 3rd friend I've talked to lives in wisconscin on spectrum. I'm on windows 8.1 and one of my other friends is on W10. We all lag in Bjoras at the same time when it's lagging.

I'm a computer science major with a RHCE cert, I'm pretty sure I understand basic networking issues.It's NOT me.

Well, I’m not lagging. There is obviously an issue you are missing. Did you run a diagnostics check? Did you post the findings on the board and to Anet? There are tons of variables not related to Anet and it’s not always Anet’s fault, so did you take all the appropriate steps?

Link to post
Share on other sites

@Swagger.1459 said:

@"Randulf.7614" said:They are investigating it already

Posts about this started months ago, I found a reddit thread complaining about it 2 months ago. Did they JUST start working on it or has it been something they've been working on for 2 months+ now?

It’s probably more helpful if you spent time looking at developer comments on the forums. Posted 6 days ago.

Also, it’s an area that Anet constantly works on. Has been since day 1. So, yeah.

Edit- I do not lag anywhere in pve, only wvw during certain instances. Maybe your computer is the problem? Maybe your ISP is the problem? Do your own diagnostic checks before you blame Anet for anything.Excuse me, what?I live in FL on ATT&T, my friend lives in new zealand, my other friend lives in russia, and my 3rd friend I've talked to lives in wisconscin on spectrum. I'm on windows 8.1 and one of my other friends is on W10. We all lag in Bjoras at the same time when it's lagging.

I'm a computer science major with a RHCE cert, I'm pretty sure I understand basic networking issues.It's NOT me.

Well, I’m not lagging. There is obviously an issue you are missing. Did you run a diagnostics check? Did you post the findings on the board and to Anet? There are tons of variables not related to Anet and it’s not always Anet’s fault, so did you take all the appropriate steps?

If this isn't a problem for you, why are you here just to tell people that there isn't a problem?

Link to post
Share on other sites

@"Yggranya.5201"

Not all players are having issues as cited by the word “some”... https://en-forum.guildwars2.com/discussion/111982/an-update-on-game-performance-issues

So those players who are experiencing issues could do a more thorough review on their end. Not all issues rest at Anet’s feet, so I’m guessing it would be helpful to provide as much information to Anet as possible.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...