Jump to content
  • Sign Up

Recommended Posts

Hi folks! The update of October 17, 2017, included high DPI aware UI scaling. Since many of you seem to have questions and thoughts about this, we invite you to use this thread for your feedback.

Here's a brief description of how it works: macOS and Windows provide a UI scaling value, usually based on the monitor resolution and dimensions. As of Tuesday's patch, we use this in the 64-bit client to scale the in-game UI as well. You can change it in your OS settings, but each OS version will have the setting in different places so please consult your favorite search engine to determine how to change that setting, if you wish to do so.

We do want you to know that we are aware that there have been crashes related to this feature, and we hope to have fixes for those very soon. In the meantime, please share your other feedback in this thread.

Link to post
Share on other sites
  • Replies 103
  • Created
  • Last Reply

Top Posters In This Topic

My GW2 client had to repair data this afternoon, I don't know if that has anything to do with the issue. And the launcher was massive when I opened the game up but the UI was fine, didn't stick on DPI scaling, thank god, some people said that happened to them. ( By the way, as Boysenberry said, don't make it the default, it freaked me out when I opened the game yesterday. )

Link to post
Share on other sites

I want to know if the issue of the DPI setting not remembering itself will be addressed. I have tried the supposed "fixes" to this (such as toggling with other settings to make it remember the checkbox, going into the actual game shortcut settings, etc) and none have worked. It's really annoying to have to go into my graphics settings and uncheck this feature every single time I log in, unless of course I feel like playing with a massive and blurry UI. I have even had it check itself back on randomly while I was playing the game. I'm glad the crashes are being looked into, but to me this is far more irritating than my game going down once in a while (since I know that crashes are always eventually resolved).

Link to post
Share on other sites

It was annoying to have this turned on by default as it looked horrible on mine. What was more annoying was the fact it wouldn't save when I unchecked the option. Thankfully someone on here posted a workaround of changing a second setting, like shadows, to force the game to save the settings. Thankfully that worked.

Having it unchecked though hasn't changed the launcher back to normal size, and hasn't put the launcher back to the centre of the screen. (since the update launcher is about 1.5x bigger and appears near the bottom of the screen, with the lower half of it containing the buttons cut off the bottom). Is there a fix on the way to change that back to how it was before the update?

Link to post
Share on other sites

I had no issue with it. I unchecked the box though, because I don't need it (running 1080P) and it makes no difference for me either way. Some others have reported that unchecking the box didn't 'stick' for them, so I tested this by exiting the game and restarting it. The box remains unchecked for me.

Link to post
Share on other sites

I appreciate that my mini map is now a reasonable size (really the only issue I had before even on the largest interface size). However, with DPI scaling, text and other stuff does not seem as sharp as before. So there certainly seems to be something of a trade off here - better sized UI elements at expense of sharpness. I'm running at 4K on a 40" monitor, so perhaps this is more an issue with this setup.

Link to post
Share on other sites

@"Jon Olson.8439" : I'm also experiencing the issue of the DPI Scaling setting not saving. In fact, after testing, of the few graphics options I tried to test, none of my graphics settings changes are saving. It's worth noting that I have not tested every setting option under the Graphics tab, but rather only a handful. In %appdata%/Guild Wars 2/, the GFXSettings.Gw2-64.exe XML file is not updating when I change settings and close the GW2 client. I imagine it's meant to. (Unless it's a "default settings" file?) I use the 64-bit GW2 client, and editing this file does change my settings when I load the game.

For example, I was able to default the DPI Scaling setting to off by finding its corresponding line in the GFXSettings.Gw2-64.exe XML file...

<OPTION Name="dpiScaling" Registered="True" Type="Bool" Value="true"/>

...and changing Value="true" to Value="false".

So, instead of being unable to keep DPI Scaling disabled when I restart the client, DPI Scaling now turns itself off every time I restart the client.

All of this is, of course, a new issue that only popped up after the recent patch which introduced DPI Scaling as a setting.

Link to post
Share on other sites

Running 1920x1200 windowed fullscreen with an interface size set to Larger, most text elements are now blurry. Thankfully not the chat window. Small, Normal and Large are fine as before.

Comparison Large / Larger

I've tried the in-game DPI scaling checkbox as well as switching between Application / System from the 'Override high DPI scaling behavior' dropdown of the Gw2-64.exe properties, to no avail.

Link to post
Share on other sites

I think it has promise, but...

At some point, my performance (MacOS 64-bit) has fallen off, so I decided to try running at the second-highest resolution, which definitely helps. But that also puts me into a weird place with DPI scaling. If I turn it off, things are so small that Large doesn't do the job, but if I turn it on, things are so large that Small doesn't do the job. What I'd want would be if I could turn DPI scaling on, then have an Extra Small setting.

One of the annoying things with DPI scaling on and using Small is that things are so large that the chat text can't fit between the left side of the screen and the icon bar, so it gets scooted up into my field of view, which is very annoying. The only choice I have is to move the chat to the top of the screen and have the party swap to the bottom, which is better functionally but aesthetically really puts the text over top of everything I want to look at.

Link to post
Share on other sites

I have just tested Vandril.3490 's idea on my 32 bit client, wherein the DPI Scaling option cannot be disabled due to the Tickbox being greyed out - and it appears to be working.

The DPI Scaling option is now unchecked, but still greyed out, my graphics are back to normal, and the setting has persisted through several restarts.

  1. Take a backup copy of the file : C:\Users\\AppData\Roaming\Guild Wars 2\GFXSettings.Gw2.exe.xml
  2. Edit the original file, changing the text :
    to now read :

Note: - change just the last value to "false".

Link to post
Share on other sites

Well, unchecking the DPI box definitely works, but it defaults back when I relog. I'm not exactly sure I understand what do here as Pookie suggested since I don't like to mess around with the properties portion of the files.This is making my eyes water and giving me headache.The log in screen takes up almost my entire desktop as well.

@Pookie.1078 said:I have just tested Vandril.3490 's idea on my 32 bit client, wherein the DPI Scaling option cannot be disabled due to the Tickbox being greyed out - and it appears to be working.

The DPI Scaling option is now unchecked, but still greyed out, my graphics are back to normal, and the setting has persisted through several restarts.

  1. Take a backup copy of the file : C:\Users\\AppData\Roaming\Guild Wars 2\GFXSettings.Gw2.exe.xml
  2. Edit the original file, changing the text :
    to now read :

Note: - change just the last value to "false".

Link to post
Share on other sites

Known good way to save DPI scaling setting without mucking about with files:

  1. While in game, toggle DPI scaling to whichever setting you want.
  2. Toggle Shadows to any other setting (doesn't matter what)
  3. Quit to desktop
  4. Relaunch the game
  5. Toggle Shadows back to the way you had it before

DPI Scaling will now be saved the way you want it. This is apparently a long-standing issue that has worked with other settings that wouldn't save in the past.

If things still aren't working, did you set your settings file (whichever it might be) to be Read Only in a previous attempt to force settings to save and then forget about that?

Link to post
Share on other sites

@Malikah.3761 said:Running 1920x1200 windowed fullscreen with an interface size set to Larger, most text elements are now blurry. Thankfully not the chat window. Small, Normal and Large are fine as before.

Comparison Large / Larger

I've tried the in-game DPI scaling checkbox as well as switching between Application / System from the 'Override high DPI scaling behavior' dropdown of the Gw2-64.exe properties, to no avail.

So i did not imagine that. I have the same resolution 1920x1200 and have the same Problem. I have the window set to fullscreen.

Link to post
Share on other sites

The issue with DPI scaling that I am experiencing (in addition to the "no save" issues above - which seem to be fixed by checking/unchecking another setting), is that when DPI scaling is turned on, the mouse pointer is HUGE. The pointer size does not change with the ui size setting; therefore, I can't run with DPI scaling on.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...