Jump to content
  • Sign Up

Attuning and Infusing rings doesn't always work.


Recommended Posts

I tried infusing and attuning my rings today but the Mystic Forge was really picky on how i did it.

See picture:https://imgur.com/4TLKX9D

I had the correct recipe, but i had to clear and redo the recipe several times before it would let me attune the ring.Same happened with infusion. At first i thought it won't let it because the stacks were too big so i split them, but even then, the correct items were greyed out in the left panel, same as with attuning the ring. Philosopher's stone was greyed out when i tried to attune the ring, and every component except the ring itlself was greyed out when i tried to infuse it.

It took several attempts at both, putting in the forge and taking it out for the forge to recognize the recipe and let me do it. Otherwise, the "Forge" button was greyed out.

Link to comment
Share on other sites

I used the same order, and eventually it worked. The problem was initially, that all the items were greyed out. Usually the items you can use light up.Then they weren't greyed out anymore, but the recipe wasn't recognized lol.

Then finally after changing nothing, it worked. :tongue:

Oh well. Berserker's rings infused and attuned, 3 infusions in, i can run T3 and i just thought i'd post this in case Anet finds this useful.Also, because i never encountered it before, and i used the mystic forge for armor stat changes and stuff... Never happened before now.

Maybe it's lag or something? I don't know...

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...