Jump to content
  • Sign Up

Game stuck at loading with 27 000~ files left


Recommended Posts

Good day mate, and welcome to the exclusive club of people who can't get into the game! I have the same exact problem, the difference is that my installer stops at 36k files, and that it keeps downloading and increasing filesize, despite the files not actually being downloaded. I wonder if this is tied to the last living world releases? No idea really. Either way, this has happened to me 2 times before, over the span of 4-5 years, with different computers, locations and ISP's, and you gotta ask yourself how the kitten the installer is in such a state... so many years into development. I'm trying to find a solution, and tried to troubleshoot 10 different things, without any help whatsoever. Seeing this post made things just way worse heh. I hope you find a way! I will let you know if I do... 🙏

Link to post
Share on other sites
On 5/4/2021 at 11:58 AM, TalleFjanten.7159 said:

Anyone have encountered this bug and know how to fix it? I can log into the game but the game launcher got 27 000 files remaining and the remaining file count dont seem to go down.


@TalleFjanten.7159 - mate! What helped me, was getting a VPN! Even as the limited data for the VPN ran out, it still continued to download! I advice you to try to get "TunnelBear" or "ProtonVPN" 🙌🙏

Link to post
Share on other sites
Posted (edited)

try to add this line: 52.202.130.147 assetcdn.101.arenanetworks.com in Local disc> Windows>System32>drivers>Hosts. Also make all files readable otherwise it wont work.

Edited by Oak.7492
  • Like 1
Link to post
Share on other sites
On 5/9/2021 at 8:14 AM, Oak.7492 said:

try to add this line: 52.202.130.147 assetcdn.101.arenanetworks.com in Local disc> Windows>System32>drivers>Hosts. Also make all files readable otherwise it wont work.

Thank you!
This solved my issue.

Not sure if I should remove the -assetsrv assetcdn.101.arenanetworks.com from my settings.json

 

Link to post
Share on other sites
2 hours ago, kanemi.4903 said:

Not sure if I should remove the -assetsrv assetcdn.101.arenanetworks.com from my settings.json

 

It has no effect - you've specified to use assetcdn, which is what it uses by default. Also, -assetsrv has been broken/disabled for over a year now, so it's just being ignored.

 

 

Link to post
Share on other sites
On 5/9/2021 at 2:14 PM, Oak.7492 said:

try to add this line: 52.202.130.147 assetcdn.101.arenanetworks.com in Local disc> Windows>System32>drivers>Hosts. Also make all files readable otherwise it wont work.

It says I dont have the permission to make changes to this file. This is the admin (and only) user on this PC so not sure what to do here.

 

As a side note, I can also play the game just fine through a VPN. 

Link to post
Share on other sites
On 5/9/2021 at 1:14 PM, Oak.7492 said:

try to add this line: 52.202.130.147 assetcdn.101.arenanetworks.com in Local disc> Windows>System32>drivers>Hosts. Also make all files readable otherwise it wont work.

Ty this fixed my problem too!!! 👌, I wasn't able to start the game, repair the game or uninstall the game, and all I got was tons of guild wars 2 instances in memory.

Task Manager

But now the question to ANET: Why after the "patch" i had to modify my hosts file to let the game work? last time was because You messed up with YOUR servers, what about now?

Link to post
Share on other sites
3 hours ago, Strigidae.1450 said:

It says I dont have the permission to make changes to this file. This is the admin (and only) user on this PC so not sure what to do here.

 

Being on an admin account doesn't mean you always have admin privileges. You run a program as an admin by right clicking it and choosing to run it an administrator, so search the start menu for notepad > run as admin, then you can make changes to the hosts file.

 

For more information:

https://en-forum.guildwars2.com/topic/95379-how-to-fix-the-download-refusing-to-continuestuck-bug/

 

3 hours ago, nargilli.6987 said:

But now the question to ANET: Why after the "patch" i had to modify my hosts file to let the game work? last time was because You messed up with YOUR servers, what about now?

 

Generally this problem is indeed caused by the server. The mirror servers the client uses by default can be interrupted while they're originally obtaining obtaining the patch files, causing the affected servers to host incomplete files. When GW2 tries to download these files, it will fail and GW2 will attempt to download it again several times, eventually aborting altogether without even showing an error.

Link to post
Share on other sites
4 hours ago, Strigidae.1450 said:

It says I dont have the permission to make changes to this file. This is the admin (and only) user on this PC so not sure what to do here.

 

As a side note, I can also play the game just fine through a VPN. 

Just open the notepad as an admin and from there you open the hosts and
add the line.

 

Link to post
Share on other sites
9 hours ago, Healix.5819 said:

 

It has no effect - you've specified to use assetcdn, which is what it uses by default. Also, -assetsrv has been broken/disabled for over a year now, so it's just being ignored.

 

 

I'm gonna remove the line from my settings.json.
Since it's not working it doesn't make any sense to leave it there.

*somebody need to edit the Wiki then.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...