Jump to content
  • Sign Up

Scourge UI Bug : 4 weeks, 5 or 6 patches, STILL NOT FIXED!!!


Recommended Posts

Posted (edited)

Hi,

 

There is a UI bug when playing a Scourge in a Dragon Response Mission...

 

Picture of the bug

 

Normally, there is a three-squares indicator of how many Sand Shades you have active, and the Lifeforce bar is yellow, running the whole length of the 1 to 5 area.

 

However, in Dragon Response Missions, the Sand Shades indicator has vanished, and the Lifeforce bar is now green, and smaller, not quite running the width of the F1 to F5 area.

 

Thanks,

 

A Scourge who can't keep count of her Sand Shades in her head...

Edited by Bugrup.4562
  • Like 2
Link to post
Share on other sites
Posted (edited)

Same here. At one point, it fixed itself after respawning at the WP. But after the cinematic, it changed back "green bar w/o shadecounter".

Edit: I haven't tried it with the one big shade, so I don't know if the problem exists there as well..

Edited by lokh.2695
  • Like 1
Link to post
Share on other sites

Yes, same for me. So far every map I have been on and wvw this occurs. If I use mount or a skill my shade icons change and my life force bar turns green. Waypointing turns it back to normal until I mount or use a skill. My damage seems/feels off/less but I didn't use Arc before patch so I can't compare.

Link to post
Share on other sites

Thanks to everyone who said it was linked to mounts, I've confirmed it's the same for me, every time I dismount I'm bugged.

 

5 hours ago, Sinn.7930 said:

My damage seems/feels off/less but I didn't use Arc before patch so I can't compare.

 

I tested my damage on the golem before and after the patch, just me, me with the arena buffs, and with my usual group. In all cases my DPS was up:-

 

Just me : 12% DPS increase

 

Arena buffs : 17% DPS increase

 

Usual group : 11% DPS increase

 

That was with the exact same gear and spec.

  • Like 1
Link to post
Share on other sites

It's not just mounting.

It's also any kind of transformation.

 

For example in raids the dhuum encounter. If you do greens or at 10% phase you get ported up to gather the orbs. After you did the mechanic, the bug occurs.

 

45 minutes ago, Bugrup.4562 said:

Thanks to everyone who said it was linked to mounts, I've confirmed it's the same for me, every time I dismount I'm bugged.

 

 

I tested my damage on the golem before and after the patch, just me, me with the arena buffs, and with my usual group. In all cases my DPS was up:-

 

Just me : 12% DPS increase

 

Arena buffs : 17% DPS increase

 

Usual group : 11% DPS increase

 

That was with the exact same gear and spec.

Scourges dmg went up by 7k on golem (29k pre patch, now 36k)

Depending on encounter you can squeeze out almost the golem numbers, sometimes even higher (but needs adds to epi bounce) 

  • Like 1
Link to post
Share on other sites

Been a week and a half now, be nice if we could get a fix for this.

 

I'd really like to be able to use my mounts, use various story quest items, or join in fights where I might get CC'd, without having to camp to the character screen and come back to fix my UI afterwards...

Link to post
Share on other sites
  • 2 weeks later...
  • Bugrup.4562 changed the title to Scourge UI Bug : 4 weeks, 5 or 6 patches, STILL NOT FIXED!!!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...