Jump to content
  • Sign Up

Low FPS / Lag Issues [MERGED]


Recommended Posts

I don't get constantly low frame rates like some others, but I've seen some serious frame rate drops. I specifically noticed it in the the PoF maps, which I started playing after Halloween. One specific instance that comes to mind happened in Vabbi during the event at Sebelkeh. After regrouping at the Market Ruins WP for the final stage, gliding down to Sebelkeh on the skimmer, the frame rate dropped to under 10fps, when I typically get much more than that. It seemed to affect most of, if not the entire instance as others were also complaining. Some of us also got dismounted from the skimmer as a result and fell to the ground. The frame rate drop typically seems to last for about 30 seconds and then recover to normal levels.

  1. First noticed after Halloween when I started map completion in PoF, which I had purchased a few weeks previous to that. I had done a bunch of stuff in HoT and finished up S3 before Halloween, then focus on the halloween events before starting with PoF. Not sure if it's related, but one thing I noticed during Halloween this year is I seemed to get way more desynced Clock Tower instances than in previous years, but that may have been more from the Comcast issues.
  2. Intermittent with extreme drops to under 10fps that last for ~30 seconds.
  3. Western Canada
  4. Crystal Desert

System specs:Windows 10 Ultimate (With the fall update installed)i7-7700K (Liquid cooled)eVGA nVidia 1080gtx (Most current driver)16GB RAMIntel 512GB 6gbps M.2 SSD System drive (GW2 is on this drive)Razer Abyssus V2 gaming mouse (Synapse is NOT installed.)Fujitsu PS/2 commercial grade mechanical keyboardASUS VG278HE 144Hz Monitor1920x1080Internet connection: 30Mbps down / 12Mbps upNo overlays, no chat program, no 3rd party firewall/antivirus

I have not noticed this on my laptop, which I've typically used solely for map completion due to it being so old. Standing still in a quiet area of the map, I'm lucky to get 30fps and roaming about, I might get as low as 12fps. So if I was hit with a frame rate drop with these levels, it would cripple me. The specs are

Windows 10 Ultimate (With the fall update installed)i7-Q740 (This is a first generation i7)eVGA nVidia 445m gt (Most current driver)1600x9008GB RAM

Link to post
Share on other sites
  • Replies 404
  • Created
  • Last Reply

Top Posters In This Topic

  1. When did this issue first start? at 25 november 2017 (between 23 and 27 november i got it for first time i think) i remember i got huge fps drops when i did this jp.(Tears of Itlaocol) for nevermore 3. completed nevermore 3 at 27 november 2017 and i got the fps drops few days before at old pc somewere else. and because 25e was saturday i think its that day.
  2. i got it first the huge fps drops at my old pc. i thought it was the old amd cpu. but when i got home i also got huge fps drops. sometimes it was 5 minutes heavy fps drops below 10 fps. no matter what i tried it didnt got better.
  3. Has it been consistent across time, or has it become worse lately? Or has it come and gone (been intermittent) over time? now its better, but it came with a big patch. some days before 25-11-2017 (i go check after this post)
  4. What is your general geographical location? the Netherlands
  5. On what game world are you playing? far shiverpeaks

specs old pc

cpu amd fx8120 3.1 or 3.2 ghzgpu msi gtx 1060 3gbram 1600 mhz corsair vengeance 2x8 gbinternet there 50 mb down and 3 or 4 up.windows 7 ultimate 64 bitgame is on hdd

better pc at home

cpu intel i7 6700k 4ghzgpu evga gtx 780ti classified 3gbram 2800 mhz corsair vengeance 2x8 gbinternet 50/50 fiberglasswindows 10 pro 64 bitgame is on ssd

its not the problem of the pc because i got it with a patch. it was fine before. with intel pc i had very good fps also with high settings.and there i also got fps drops.

Link to post
Share on other sites

reposting from another thread:ive been getting massive frame drops to where the game is unplayable (5 fps) even in non intensive gameplay like running around wvw (not in a fight), and i have to restart the game. this happens almost nightly and it's getting really annoying. Ive tried turning off shadowplay (havent had it on for the last 2 months), turning graphics to best performance (low everything), i dont have arc dps. sometimes the game will recover after a few minutes other times it becomes completely unplayable.

i7 7700k OC'd @ 5.1ghz1080ti32gb RAMgame is on SSD

i dont want to hear "get a better PC" i dont have these issues in other games. the only other game is GTA 5 but that game has a known issue of not liking GPU overclocks (works fine with no OC)anet fix your game

Link to post
Share on other sites

@"MadBomber.3719" said:i dont want to hear "get a better PC" i dont have these issues in other games. the only other game is GTA 5 but that game has a known issue of not liking GPU overclocks (works fine with no OC)anet fix your game

GW2 is also known to dislike over clocking. I had to down clock the video card on my old machine in order to stabilize the game. The machine works fine for everything else. It was in a sticky post related to crashing on the old board. Not sure if that posting came across to the new board. That said, I think these current frame rate issues are more related to the server than the client-side hardware setup since when it happens it tends to affect an entire instance, or at least groups in the vicinity of each other.

Link to post
Share on other sites

@Leamas.5803 said:

@"MadBomber.3719" said:i dont want to hear "get a better PC" i dont have these issues in other games. the only other game is GTA 5 but that game has a known issue of not liking GPU overclocks (works fine with no OC)anet fix your game

GW2 is also known to dislike over clocking. I had to down clock the video card on my old machine in order to stabilize the game. The machine works fine for everything else. It was in a sticky post related to crashing on the old board. Not sure if that posting came across to the new board. That said, I think these current frame rate issues are more related to the server than the client-side hardware setup since when it happens it tends to affect an entire instance, or at least groups in the vicinity of each other.

I will try turning off OC completely tonight but so many people having same issue and probably havent OC'd their GPU, so im doubtful thats the issue. people are telling me to clear gw2 cache so i will try that as well

Link to post
Share on other sites

@MadBomber.3719 said:

@MadBomber.3719 said:i dont want to hear "get a better PC" i dont have these issues in other games. the only other game is GTA 5 but that game has a known issue of not liking GPU overclocks (works fine with no OC)anet fix your game

GW2 is also known to dislike over clocking. I had to down clock the video card on my old machine in order to stabilize the game. The machine works fine for everything else. It was in a sticky post related to crashing on the old board. Not sure if that posting came across to the new board. That said, I think these current frame rate issues are more related to the server than the client-side hardware setup since when it happens it tends to affect an entire instance, or at least groups in the vicinity of each other.

I will try turning off OC completely tonight but so many people having same issue and probably havent OC'd their GPU

I have the same CPU (Stock clock though), with a 1080gtx, so similar system, and have seen these frame rate dips. Like you say, it doesn't hurt to check, but in this case with probably not help.

Link to post
Share on other sites

But when playing GW2 on "Best Appearance" i get like 30 FPS and when i look around with my mouse it lags in a odd way.

Best RegardsStefan RumleBest Appearance has high character model limit and ultra shadows. If you turn those down you'll benefit immensely.Also, keep an eye on Field of View settings, and 'maybe' Native Sampling might behoove ya.

Link to post
Share on other sites

@SgtSarcasm.1653 said:Hi,

I've recently returned to GW2 after several years away, and I'm running it on a brand new desktop PC.The specs on my computer are: Intel Core i7-7700, GeForce GTX 1080 Ti, 16 GB DDR4 2666 MHz. I'm also running the game from an SSD.

I tested my FPS on Heaven Benchmark 4.0 on highest possible settings @ 2560x1440 and got ~80-100 fps on most scenes, occasionally dropping down to a steady 60-70 fps on some more intense scenes.

However, when running GW2 I sometimes randomly start getting really low fps (30-40), even personal story instances and fractals. I could understand it if I only got fps drops during massive world event bosses or similar situations, but a lot of the time during world event bosses I have a solid 80+ fps.

Any help with fixing this would be appreciated, as this is really frustrating.

I had identical problem, nearly identical machine except im running the i7 8700k. So even with the new cpu the problem exists. It's not our machines, most ppl experience this and ive simply gotten used to it. I use all max settings except character limit is one below max, if you have that maxed try bumping it down 1 notch but unless you are lagging completely out or freezing every 10 minutes id advise to just accept it and hope for a fix like the rest of us with very high end rigs and ok performance on this game only.

Link to post
Share on other sites

@"Gaile Gray.6029" said:Hey folks,

There were quite a few individual threads about FPS concerns. Whether you have a new PC or an old one, whether you just joined the game or have played for years and have noticed recent decreases in your FPS, it seems prudent to merge the threads into one and relay a request internally for someone to take a look. I know that merging sometimes somewhat "garbles" the conversation, but this is an important issue, and the breadth of reports in a single merged thread only helps to emphasize your concerns. So I hope you'll be ok with the merge, and of course if other players have issues with FPS, please add them here.

NOW... having said that, I believe that it would be super helpful for you to tell the team a few things:

  1. When did this issue first start?
  2. Has it been consistent across time, or has it become worse lately? Or has it come and gone (been intermittent) over time?
  3. What is your general geographical location?
  4. On what game world are you playing?

If you can edit your posts in this thread, or post a new one in this thread with more information, we'd really appreciate it!

Thanks so much!

Having this looked at would be phenomenal!!!! This was such a bummer for me when I installed gw2 on my new machine and at first was blown away then the frames crashed so hard it was like a frame by frame video slideshow. Im talking areas where theres not another player in sight and just a few random mobs. Of course huge zergs frames would drop on nasa's rig but thats understandable. It has improved slightly over time but when I made my post about this I got countless people in the same boat. Every other game we play, almost all more demanding than gw2 under normal circumstances, run maxed with ease so it didnt make sense, still doesnt. Thanks and I hope someone does care to try and figure this one out.

Link to post
Share on other sites

UPDATE: ran repair twice yesterday and deleted my gw2 cache. i did not experience any FPS drops last night. I did not turn off GPU OC. hopefully i have fixed my issue. knock on wood For those dropping frames try deleting your gw2 cache. Ofc its only been one night, will update if problems persist.

While I was going through the folders to delete the cache i noticed this https://imgur.com/ebbWkz9this cant be normal

Link to post
Share on other sites

1. When did this issue first start?FPS drops in certain crowded situations (i.e. world bosses) were in the game from day 1.

2. Has it been consistent across time, or has it become worse lately? Or has it come and gone (been intermittent) over time?FPS drops have become more frequent and severe since the first expansion and are now at a point where much of the group content is virtually unplayable for me. I have employed every optimization trick on the net, but with great sadness, GW2 is on hold until these issues are resolved.

3. What is your general geographical location?Ohio, USA

4. On what game world are you playing?Tarnished Coast

AddendumTo rule out internet speed and ping issues, my PC is hard-wired to a network that operates at 118/12 mbps and 12 ms ping. To put it plainly, I am bewildered how a modern PC system assembled in 2017 has trouble maintaining 40-60 FPS in a 5-year-old game. I fear that the coding troubles of this game are so deeply entrenched that a "fix" may involve a lot more effort than is economically feasible. Hence, the problem persists to this very day and continues to exacerbate with each large content addition.

I hope GW3 gets this sorted out if there is to be a GW3. But for now, I'm not very hopeful that these FPS problems will be resolved seeing how long this has been going on.

Link to post
Share on other sites

@"MadBomber.3719" said:While I was going through the folders to delete the cache I noticed this https://imgur.com/ebbWkz9this cant be normal

Wow, not normal at all! I'll check my cache as well. This is precisely the sort of coding issue that I've been concerned about: the problem seems "fixed" after the cache is deleted, then all these corrupt .dat files pile up and we're back to the same situation.

Link to post
Share on other sites

Just coming in to confirm (mostly) what others have said.

Currently running:Windows 10 Pro x64 (kept very clean and running well)AMD FX-8300 8 Core Processor @ 3.3GHzNVidia GeForce GTX 1050 Ti16 GB RAM

My desktop isn't the best thing ever at all, but it should definitely be MORE than enough to run this game at max settings, 60 FPS easy. Instead I'm getting 26 FPS at around medium settings at 1440x900. Power settings are all set for maximum performance. Yes, I checked each individual advanced option myself. I've been having this issue for a long time (on another PC too) but I never really said anything about it until now.

Link to post
Share on other sites

I've been having issues on and off since November but last couple of weeks FPS is in the region of 5-15 in raids, PoF and HoT. On older Tyria maps back up to low 20sIstan map - the bone wall was a major lag fest any time I went to that part of the map. But this constant low FPS is more recent.

I put it down to my graphis card issues long story but part story https://en-forum.guildwars2.com/discussion/comment/315345#Comment_315345 so was thinking it might have been that but.....

summary is I have had 3 graphics card in the computer in the last few weeks.

MSI Radeon R9 380 Gaming 4GB - originalGigabyte Aorus RX580 8GB - newand my back up card which use to run GW2 just fineMSI Radeon R270 2GB -

All 3 cards now run GW2 at the same poor low FPS.

running Win 7, with 16mb RAM, i5 4690.

Now what is really baffling is my son is running GW2 five yards away on an older computer/grahics and getting great FPS with High graphics settings.

I've tried repair/ deleteing cache / Reinstalling files from one SSD to another. Updated graphics drivers, backdated graphics drivers, over clocked and underclocked CPU. Hardware monitor. shows now excessive heat to CPURun malawarebytes, AVG and CCleaner. -

Other games like Dishnoured 2, Civ 6, Rimworld run fine.

It seems reading through this thread that it does not matter if it is Nvidia or AMD grpahics something is badly broken.

Link to post
Share on other sites

Okay since todays update we have fps back to where it should be.

Now the update is probably just co-incidence as I stripped my computer down and refixed the heat sink, added a case fan and oh yes put a new PSU in the box! So even though the old Corsair 650 was less than 18 months old the new 750 seems the most likely solution.

So far so good fps back up to 55 ish until Istan map and Champions Dawn where it drops to15-20 but at least it is now playable. And maybe if I whisper it quietly no graphics crashes.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...