Can't login or play, no access to login servers — Guild Wars 2 Forums
Home

Can't login or play, no access to login servers

Hello there
not so recently, there's been a big issue for players who enjoy playing this game from Iran and it is the problem with login servers blocking IP addresses from Iran or something of that sort. so we need to be using VPN in order to be able to login to the game and THAT is ridiculous. i didn't play the game much ever since PoF and now that i'm returning, it's just annoying.
considering how i don't recall anything on ToS about Iranian players being locked out of the game or banned from playing when i bought the original game before release and then later on during HoT days, i would very much like a clarification on this from A.Net and how they might be planning on addressing the issue.

Comments

  • Perhaps, it's not ArenaNet blocking, but someone else. Sometimes, internet providers or governments block places.
    You can contact the CS Team via the 'Support' link above/below.

    Good luck.

  • Tried looking around about the issue and it's most likely caused by amazon servers. one way or another, definitely not an ISP issue. it's on the server side and doesn't look like much of a good policy to screw quite a few players without any prior notice and support, blocking the IP addresses from Iran entirely.
    and of course there's still no comment from A.Net, guess support tickets are the way to get a response.

  • just giving this topic a shameless self bump since the support crew just claims the issue is not from A.Net's servers despite how i said it's Amazon's servers causing trouble with solid proof via traceroute on any GW2 related IP i could find during login process. oh and also they refuse to give an IP address i could tracert to check if it is indeed a server-side issue or not.

  • You are aware you can't ping (trace) AWS servers, normally, as Amazon blocks all pings?
    You need to change how you ping.
    Also, you can find the IP address of any map using the chat command, /IP or the command line argument, -mapLoadinfo

    Good luck.