Nevermore IV: Raven Spirit bugs? Unable to interact with 2-3 places — Guild Wars 2 Forums

Nevermore IV: Raven Spirit bugs? Unable to interact with 2-3 places

I am unable to interact with Jora, Grenths (in lornars) or Viewing Hill plaque. The items are in my collection and should have worked. One of the 3 i got last night worked fine (god's hand). So what am I possibly missing for these particular ones? I have Dwarven to do and at 56/63 items in collection. Of the 53 I got 2 or 3 of them last night.

Frustrated as wiki tells you nothing in particular other than to go here and do this! Which I've done! What the hell am i missing here?

Thanks for any input to resolve these 3.

Mike aka Quickshot Kometh in game.

Comments

  • Hmm, no insight or anything from the devs?

  • Linken.6345Linken.6345 Member ✭✭✭✭

    So you brought the Phantom residue from shadow behemoth with you to lornar pass?

    https://wiki.guildwars2.com/wiki/Phantom_Residue
    Do not destroy this trophy immediately; it is required for a later step.

    Same on jora your supposed to bring a thing to it.
    Bring the Ancient Svanir Relic to rest at the foot of Jora's statue in Wayfarer Foothills.

    and the red iris flower from urban battle grounds to hill plaque
    Collect a Red Iris Flower from the Urban Battleground fractal and bring it to rest at the Viewing Hill plaque in Plains of Ashford.

    So either you destroyed these or got them on another character.

  • Well looks like i answered my own question. First time gets item into collection, 2nd run you then can use at the interaction location. Close thread please. All set, have to redo the maps 2x vs once. As i did shadow behemoth for phantom residue (was in collection) and once i completed and went to location, it finished....great...

  • Hmm, I will go on my Guardian whom i usually run fractals on due to having most AR. Maybe that'll get the ones i have done in past completed for collection. I didn't think to go on toon that's done then previously.

  • Linken.6345Linken.6345 Member ✭✭✭✭

    You can get it from the level 2 or 3 stage need no ar there.

  • Yeah, it's what i did the other night. Have to do dwarven anyways, and the other 2 again to get the item. At least now i can continue this trek.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.