Jump to content
  • Sign Up

Launcher opening then closing immediately

Recommended Posts

I've been having this problem for the past few months now. When I open my game, the launcher shows for a second or two, then closes itself immediately. The repair client does the exact same thing. I've got my game to work a total of 3 times in the past few months, and I don't know what changed. I thought it was my schools wifi, but even when I turn off wifi and ethernet, it still happens. I went through my firewall and allowed it specifically. I tried running with admin. I tried turning off my antivirus. I tried uninstalling, and then I couldn't install the game at all because the installer did the same thing. My old computer broke, and I got a new one. Guess what, it happened again.  I got it to work once when I restarted my new computer, and once just randomly when trying.  I'm thinking its some program running in the background interfering with the launch but i don't know. I noticed that an application called gamingservices in the WindowsApps folder, that you can't access directly, runs when I run GW2, but I can't disable it. When I close it in task manager, it just reopens when I try to launch GW2. Anybody having the same problem or have any idea what's happening?

Link to comment
Share on other sites

Check overlays and game integrity.


After a late (2 week delayed) Windows 10 Update, about the same happened to me. /repair  on the game shortcut, and fully downloading again did not work. Windows' Xbox gamebar was stopped without change. Video card driver's were noted. MSI Afterburner and RTSS were recently upgraded on a second system without problems, and after updating on problem system, resulted in no problems.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...