Jump to content
  • Sign Up

Sunrise II: The Perfected Daysword Requistion Bug

Recommended Posts

Today, I've been working on both Sunrise II and Twilight II.  Noting that after crafting 250 Basic Mithril Greatswords, one also needs an additional 250 Mithiril Greatsword Blades and Hilts, I created enough to finish the basic requisitions.  After turning in 250 Basic Mithril Greatswords for Sunrise II, there was a dialogue option for "I have the blades you're looking for right here" or similar, and a similar one for hilts.  Using this option took 250 blades, but did not progress the achievement, then took the dialogue back to the 'Ah the fabled daysword" series of options, from which I was able to successfully give the hilts.  The regular blade option also worked fine after more blades were acquired, and the regular option worked for Twilight II.  I did not test the potentially bugged option on Twilight II.

I was in the Mistlock Sanctuary, using the Master Weaponsmith there.

Support has resolved all issues on my end, and suggested I post the bug here.

Link to comment
Share on other sites

  • 1 year later...

I have issues proceeding to the second part, my first item gone missing from my warrior (Basic Mithril Daysword Requisition), it counted in the achievement, but when I try to give the items to the weapon master for the second part of sunrise II (the blades - The Art of Forging: Daysword Blade Edition) I have no visible dialogue option to proceed it. Tried this in lion arch because my warrior is human. Now I wonder do I have to craft new 250 swords to try to obtain it again or not? Im gonna test it tomorrow.

Edited by Monarch.7241
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...