Jump to content
  • Sign Up

Stuck in the PoF's story "Bringing Out the Archon" because of the bug

Recommended Posts

Hi. I'm stuck in the Path Of Fire story and can't go further. Last week I did "Bringing Out The Archon" chapter with my main character Aamitu. I replaced Joko portraits with Sunspear propaganda and assaulted Awakened's camps. When it was done and I should get a reward, I got black screen and got disconnected. When I logged back, I saw this: https://i.imgur.com/8cuGcnJ.png And it's like that for days now. Of course I tried too replay this chapter multiple times but everytime I click on the button I get the same stuck story. I know I should go to Bone Palace now but there's no green star, nothing happens when I'm there. I did the story in Bone Palace with my friends but I didn't get an option to progress so it was for nothing.

If there's no solution to this problem other than reseting the whole story - let it be. I can do it again if I have to. I started the whole PoF story with my other character but Aamitu is my main. Please, help me go further. Help me unblock the story for her.

Link to comment
Share on other sites

  • 5 weeks later...

I am having this exact same issue. The story is stuck on "Bringing Out the Archon", and I've done " Replace Joko portraits atop building with Sunspear propaganda" and "Raid Awakened camps and fly the banner of the Sunspears", yet there is no story progression.

I have notice that there are still marked spots atop buildings with green stars to change banners left, but my character can not interact with them.

I have tried to quit the story and restart, but it restarts from the same stuck position and doesn't give me a fresh restart on the mission.

This is frustrating, because I do have two other characters who have completed the mission and the story arc, so I don't know why it is different this time around.

Link to comment
Share on other sites

I have managed to get around this bug.

I went into the Hero Menu -> Story Journal and selected "The Departing" to "Replay This Chapter". This cleared any progress on "Enemy of My Enemy". Please note that I did not have to replay the chapter. just start it. I then reselected "Enemy of My Enemy which had a closed treasure chest icon next to it. This gave me a fresh new mission of "Bring Out the Archon"

I then went to town and did ALL the green star marked banner in town for "Replace Joko portraits atop buildings with Sunspear propaganda." Even after the progress bar had filled, I continued until all green star marked banners were cleared from town. I then proceeded to "Raid Awakened camps and fly the banner of the Sunspears". When the progress bar was filled for that requirement, the mission progressed to the next event "Gather information and form a strategy to recruit Palawa Joko's generals: Intercept Archon Iberu at the outskirts of the Bone Palace."

I hope this helps anyone else that finds themselves stuck with this bug.

Link to comment
Share on other sites

  • 4 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...