Bought expansions, trading post items still locked — Guild Wars 2 Forums

Bought expansions, trading post items still locked

Tried deleting cache files from temp directory, didn't help. Tried submitting a ticket, but kept telling me the page was down/moved.
How do I resolve this?

Comments

  • I'm unclear what exactly your symptoms are. The TP doesn't immediately unlock when you buy the game; there's a delay (4 days if I recall correctly). It turns out that people would use stolen credit card numbers to upgrade, then do a bunch of stuff on the TP to launder illicitly earned gold, so it just makes more sense (to ANet) to keep the TP restricted until the banks have time to confirm the purchase.

    "Face the facts. Then act on them. It's ...the only doctrine I have to offer you, & it's harder than you'd think, because I swear humans seem hardwired to do anything but. Face the facts. Don't pray, don't wish, ...FACE THE FACTS. THEN act." — Quellcrist Falconer

  • Alright, I think that answers my question. I thought it was "upgrade account OR wait 4 days", so I assumed account upgrade was an immediate unlock.

  • Already received my gems but TP items even below my level like axes and stuff are locked.

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Has it been 4 or 5 days? There are time restraints to help deter RMTrading.

  • 3 days. But should I wait at least 5 days then?

  • Inculpatus cedo.9234Inculpatus cedo.9234 Member ✭✭✭✭

    Yes, though it will likely unlock after 4 days.

    Good luck.

  • All good now! Thanks!

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.