Cannot log in to Arenanet support — Guild Wars 2 Forums

Cannot log in to Arenanet support

I can log into the game no problem. I can log into Arenanet and the forums. After I log into Arenanet and click the "Submit ticket" button, it logs me out and tells me to log in or submit anonymously. So I log in again where it takes me back to Arenanet… click support... and get logged out or it does not recognize that I am logged in. I tried two different browsers with the same result. Any help would be sincerely appreciated.

Comments

  • If you wish to submit a ticket, do so anonymously. You will receive the same service.
    And, the CS Team may be able to help with logging in.

    Good luck.

  • Bloodstealer.5978Bloodstealer.5978 Member ✭✭✭✭
    edited September 12, 2019

    Yeah it is going silly again.. not even getting a login page coming up on guildwars.com, just blank pages, so I surmise the login pages have been messed up again for IE users .. Vanilla been playing????
    As Inc said, you can still click Support and put an anonymous ticket in, I just tried and it seemed to get as far as the submit (didn't submit a ticket tho as obviously I didn't have a genuine ticket to submit)

    Someone really needs to feed them hamster's more often or get someone else to play code wars with the site.

    Life is what YOU make it... NOT what others tell you!

  • @Bloodstealer.5978 said:
    Yeah it is going silly again.. not even getting a login page coming up on guildwars.com, just blank pages, so I surmise the login pages have been messed up again for IE users .. Vanilla been playing????
    As Inc said, you can still click Support and put an anonymous ticket in, I just tried and it seemed to get as far as the submit (didn't submit a ticket tho as obviously I didn't have a genuine ticket to submit)

    Someone really needs to feed them hamster's more often or get someone else to play code wars with the site.

    Can confirm this with IE11. Came onto the forums to find I had been logged out. Attempting loggin to the forms brings up a blank page, attempting to log on via the support page brings up a blank page, attempting to log in to my account via the Guildwars2 webpage brings up a blank page. Some ones broken something. Had to use EDGE to log on :/

  • Happens every time Vanilla start playing with the spaghetti these days .. IE gets a bum deal and I find Edge makes the forums look yuk, for me at least.

    Life is what YOU make it... NOT what others tell you!

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.