OK i'm logged in here on site, BUT the game won't let me log-in — Guild Wars 2 Forums
Home

OK i'm logged in here on site, BUT the game won't let me log-in

darrkkenzi.8601darrkkenzi.8601 Member
edited January 18, 2020 in Account & Technical Support

I reinstalled the game after 5-7 year hiatus on a new comp. Played my toon (low level) for an hour & logged out. 2 days later clicked to log-in it wants my SERIAL number after refusing the saved password. BTW I payed like USD 59.95 to get it back then. I was logging in to get the new x-packs & can't even get in to the game even though I can log-in to the website to post here. I had them send me an SMS, send the code to my email, & even let THEM pick my password, NOTHING works they want me to do account recovery!!! What is this a PC game or an iphone? Make up your mind...please help. For Pete's sake the game is FREE now let me in.

Comments

  • And no I don't have a serial number it is lost 2 house remodels & moves ago...old emails are culled from time to time I must've weeded this out somewhere. Creating a new account was of no help they STILL want serial number grrrr.

  • Healix.5819Healix.5819 Member ✭✭✭✭
    edited January 18, 2020

    @darrkkenzi.8601 said:
    2 days later clicked to log-in it wants my SERIAL number after refusing the saved password.

    It asked for a serial on the launcher? Only the website should ask for a serial when recovering an account. Also note that your saved password could be incorrect, if you've never tried to re-enter it.

    Creating a new account was of no help they STILL want serial number grrrr.

    How are you creating a new account / where is it asking for a serial? A free account doesn't need or ask for a serial.

    Are you confusing the authentication code that is requested after attempting to login on a new IP? It's sent via email (default), SMS or an authenticator depending on which one you picked.

  • I did create a new account but it changed nothing, & the password was saved in the game...also I had in notepad & copied it in...no good.

  • I tried again it says there is an "unspecified error" & won't let me create a free account. Sorry forgot that part I did so many things trying to jump through the hoops. made a ticket too but no response as of yet.

  • @Healix.5819 said:

    @darrkkenzi.8601 said:
    2 days later clicked to log-in it wants my SERIAL number after refusing the saved password.

    It asked for a serial on the launcher? Only the website should ask for a serial when recovering an account. Also note that your saved password could be incorrect, if you've never tried to re-enter it.

    Creating a new account was of no help they STILL want serial number grrrr.

    How are you creating a new account / where is it asking for a serial? A free account doesn't need or ask for a serial.

    Are you confusing the authentication code that is requested after attempting to login on a new IP? It's sent via email (default), SMS or an authenticator depending on which one you picked.

    No serial was asked for IN the launcher...it was required when I tried to do account recovery option...round & round we go. with A-Net wth??

  • Healix.5819Healix.5819 Member ✭✭✭✭
    edited January 18, 2020

    If you can login to account.arena.net, that confirms your email/password and you should be able to login through the launcher. However, there was apparently a problem with using special characters in the password, which would cause the launcher to fail to login, though this should have applied to your previous login if you were affected by this.

    For a simple test, delete %appdata%/Guild Wars 2/Local.dat, (if it exists) Documents/Guild Wars 2/Local.dat, and all gw2cache folders under the %temp% folder. This will basically reset the launcher. Launch the game with the following options:

    If your account was created with a NA key:
    -assetsrv 54.84.216.160 -authsrv 34.235.245.105

    If your account was created with a EU key:
    -assetsrv 54.84.216.160 -authsrv 52.59.151.62

    (if you don't know which region you are, it's on the overview under personal information / region after logging in to account.arena.net)

  • @Healix.5819 said:
    If you can login to account.arena.net, that confirms your email/password and you should be able to login through the launcher. However, there was apparently a problem with using special characters in the password, which would cause the launcher to fail to login, though this should have applied to your previous login if you were affected by this.

    For a simple test, delete %appdata%/Guild Wars 2/Local.dat, (if it exists) Documents/Guild Wars 2/Local.dat, and all gw2cache folders under the %temp% folder. This will basically reset the launcher. Launch the game with the following options:

    If your account was created with a NA key:
    -assetsrv 54.84.216.160 -authsrv 34.235.245.105

    If your account was created with a EU key:
    -assetsrv 54.84.216.160 -authsrv 52.59.151.62

    (if you don't know which region you are, it's on the overview under personal information / region after logging in to account.arena.net)

    How do I do the "assetsrv" etc part? under settings on website?

  • I am NA just looked

  • Healix.5819Healix.5819 Member ✭✭✭✭

    @darrkkenzi.8601 said:
    How do I do the "assetsrv" etc part? under settings on website?

    You use it in a shortcut to launch the game. https://wiki.guildwars2.com/wiki/Command_line_arguments

    ... or you can just enter it into a folder's address bar like this, substituting your own path:

    C:\Program Files\Guild Wars 2\Gw2-64.exe -assetsrv 54.84.216.160 -authsrv 34.235.245.105

  • it worked TY! don't understand the ins & outs of the why it worked but GG!!

  • Healix.5819Healix.5819 Member ✭✭✭✭

    Note the command line option is temporary. If it happens again without using those options, open a command prompt (search the start menu for cmd) and enter:

    ipconfig /flushdns

    (or switch to Cloudflare or Google DNS)