Jump to content
  • Sign Up

Problem with Google Apps Script URL Fetching, error code 429


Recommended Posts


I am having some trouble with the GW2 API and some script code I am testing for a project. I am using Google's Apps Script program so I can send item info into a spreadsheet. 

I ran this code:


It worked a dozen times until recently when I started getting a "Request failed for https://api.guildwars2.com returned code 429. Truncated server response: {"text":"too many requests"} " response.


I ran the same code on my phone to check if my IP address was blocked (which seems strange because I thought the app ran in the cloud) and it ran. I ran it multiple time in a row to see if it would get blocked and it still hasn't on my phone but on my PC it's still blocked. I  then changed my IP on my modem to see if it would fix it and it worked for like 5 runs before it got blocked again.

I don't understand why because I was reading that the rate limit was 600 (per minute?) and I don't think the function sends more than one each time I run it, and I'm only running it between edits. I also should not that entering the URLs into my browser works perfectly fine, which I thought would present the same error if my IP address was indeed being blocked.

I have also ran someone else's "importJSON" code I grabbed from a website and it seems to actually work as my spreadsheet refreshes every time I run it even though it uses the same URL fetching function.

Can anyone help me with this?  I'm really stumped.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...