Jump to content
  • Sign Up

UI Timers not displaying/popping correctly - Bug?

Recommended Posts

This problem has been effecting my account for a few months now. In-game UI timers do not display correctly. Let me explain a couple of examples:

  1. In WvW, the mini map will show me that supply camps are able to be capped. But when I go to the supply camp, the veteran npc will still have 2 minutes of Righteous Indignation. The mini map is only supposed to show that a camp can be capped if the veteran npc no longer has RI. The time that the UI is off is always nearly exactly 2 minutes, as in the server is updating my UIs 2 minutes earlier than it should.
  2. In PvP, when I open the Automated Tournament panel to view AT information, it does the same exact thing. It will tell me that an AT is opened to be able to enroll a team into it, but the enroll button is greyed out. When I ask other players if the AT is open for enroll yet, they will say to me "We still have 2 minutes left" yet my UI is for whatever reason updating everything 2 minutes earlier than it should.

I've had players tell me that this was a bug related to using "Local Time" in the settings options, so I've tried using "Server Time" or even "Tyrian Time", but the same problems persists which is the server updating all my UIs about 2 minutes earlier than it should. I have even tried reinstalling Guild Wars 2 to correct the problem, and this also did not work.

I am a NA player, so we are talking about NA servers here. And honestly I don't know what could have caused the problem. I don't remember a pinpoint exact time in which this began to occur, but I did begin noticing it about 2 or 3 months ago. I figured maybe it was some kind of buggy patching and that it would fix itself in time, but this doesn't seem to be the case, and no other players I am talking to are experiencing any similar problems with game UIs being ahead of or behind schedules.

If anyone has any insight as to how to correct this issue, the info would be much appreciated.

Link to comment
Share on other sites

@Inculpatus cedo.9234 said:Have you tried checking that your computer's time is correct? (To synchronize right-click date/time in toolbar - choose 'Adjust date/time')Tried a -repair of the client?

Good luck.

That was exactly what the problem was. Somehow my PC's clock was just about 2 minutes ahead of schedule.

Thanks for taking the time to post ^^

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...