Temple of the Forgotten God Bug — Guild Wars 2 Forums
Home Bugs: Game, Forum, Website

Temple of the Forgotten God Bug

I have done this storyline on multiple characters but for some reason my thief cannot get it to update. I get to the first shrine and it doesnt allow me to advance the quest. I have been stuck on this for a couple of weeks now. I dont know what to do at this point.

Comments

  • The same thing is happening to me and it's making me very pissed off because I've found evidence that the bug has been persistent for two god damned years.

  • Well, I finally got the dumb thing to work. Basically, keep logging in and out until the stupid quest advances, it may take you repeated tries. Took me like 10.

  • Wukie.1794Wukie.1794 Member ✭✭

    Figured I would resurrect this since it is still going on. This is the first character I have had this happen to. I keep logging but no luck so far. This warrior has had THE WORST time trying to get through the personal story. The bug in Tower Down, The Battle of Fort Trinity had a mob spawn underground and it kept attacking the NPCs not letting the quest advance, so that took a restart. Now this.

  • It seems to be a reason for that... after try a lot of things looking for mobs "in the walls" I thought that maybe the mobs are not IN the "storyline dungeon". The issue is out of the instance: if there is any active event before you go into the storyline you could have this bug. So, to solve it just finish the event (or all of them around the temple) and go into the story again.

    @Sabella.6132 said:
    The same thing is happening to me and it's making me very pissed off because I've found evidence that the bug has been persistent for two god damned years.

    2 years... Really? I believe you cos it is a game full of bugs like this.

  • Still happening, i came back to try it out again and catch up with the story but i see this hasn't been fixed yet. No GW2 for me i guess

  • jtor.8192jtor.8192 Member
    edited August 16, 2019

    @owowo.6289 said:
    It seems to be a reason for that... after try a lot of things looking for mobs "in the walls" I thought that maybe the mobs are not IN the "storyline dungeon". The issue is out of the instance: if there is any active event before you go into the storyline you could have this bug. So, to solve it just finish the event (or all of them around the temple) and go into the story again.

    @Sabella.6132 said:
    The same thing is happening to me and it's making me very pissed off because I've found evidence that the bug has been persistent for two god damned years.

    2 years... Really? I believe you cos it is a game full of bugs like this.

    I am currently having the same problems and I found archived threads of this bug all the way back in 2013... Six years? Really?
    Has anyone found a solution?

  • Ozzio.8024Ozzio.8024 Member ✭✭

    Logged in and out over 20 times now, and it still wont let me progress . . .

  • And yes, the bug is still there! D:

  • This bug is still in game :cold_sweat:, please fix it :/

  • Hannelore.8153Hannelore.8153 Member ✭✭✭✭

    One thing to be careful of: Don't try to rush a quest that bugs out. As you become more desparate, you might try to rush it more and more, and that will only lead to worsening the problem; usually these bugs result from an attempt to semi-speedrun it to begin with, because enemies follow you as you rush past them and get stuck in weird locations and stuff like that.

    Take it slow, wait for all dialogue to complete, try not to outpace NPCs, etc. Sometimes bringing another player helps.

    Hannah | Daisuki[SUKI] Founder, Ehmry Bay, NA | 22 charas, 16k hours, 27k AP | ♀♥♀
    Mains Mariyuuna/Tempest & Alisha Kei/Druid(PvE), Terakura/Spellbreaker & Kitty Koume/Reaper(WvW)
    No need to be best, only good and kind.

  • Bug still a thing :(