Beetle Boost issue — Guild Wars 2 Forums

Beetle Boost issue

We need a change to the beetle mechanics so that once your endurance is maxed it can't be lost until you boost.

This isn't exactly a "bug" but it is a needless hindrance that can really mess up a beetle race time without warning. When you try to use your boost, if you are even slightly airborne through a small unexpected bump, the game "thinks" you are trying to do the air trick to regain endurance. This has a punishment mechanic where if you don't do it a certain way you lose endurance. There's no reason to punish players, though, for "failing" a trick when their endurance is full, because there's no reason for them to be trying to do the trick in the first place, and it's far too easy to accidentally be airborne when you try to boost. Then you not only don't get the boost off when you needed it, but you also get delayed even further by the endurance loss.

Compounding the issue you're probably mashing the boost trying to get it to go off and you therefore lose endurance a couple of times over the bumps. Just change this so that you can either boost in midair, or you can't lose endurance until you boost.

Comments

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭
    edited November 30, 2018

    There is a checkbox in the options menu that resolves this.

    EDIT:

    https://wiki.guildwars2.com/wiki/Options#Mounts

    Disable Conditional Mount Movement Ability Input — Disables the conditional activation of mount movement abilities on certain hot keys such as spacebar, and solely uses the mount movement ability hot keys for activation.

  • Kal Spiro.9745Kal Spiro.9745 Member ✭✭✭
    edited November 30, 2018

    Yeah, the answer to your issue is to split jumping and primary movement ability. As mentioned, there is a checkbox for that. Then you don't do tricks unless you jump, and you boost when you boost.

    Tarnished Coast Kal Spiro - Ranger (80), LB/S-D, Eagle/Wolf, Signet, M/S/NM |Daredevil|Ranger
    |Guardian|Scrapper|Necromancer|Berserker|Dragonhunter|Mesmer|Elementalist|Deadeye|Warrior
    |Herald|Daredevil|Reaper|Spellbreaker|Weaver|Chronomancer|Soulbeast|Holosmith|Revenant

  • Kunzaito.8169Kunzaito.8169 Member ✭✭✭

    I can't physically incorporate another button when doing this activity. Sorry. There's no reason for this mechanic to behave this way.

    Here's another possible solution: queue the boost to go off when you land - that way you don't mash or hold down the button to make sure the boost goes off and inadvertantly trigger the "trick" mechanic. Lots of ways to solve a clear issue that don't involve players having to adapt to an entirely new control mechanism.

  • Ayrilana.1396Ayrilana.1396 Member ✭✭✭✭
    edited November 30, 2018

    @Kunzaito.8169 said:
    I can't physically incorporate another button when doing this activity. Sorry. There's no reason for this mechanic to behave this way.

    Here's another possible solution: queue the boost to go off when you land - that way you don't mash or hold down the button to make sure the boost goes off and inadvertantly trigger the "trick" mechanic. Lots of ways to solve a clear issue that don't involve players having to adapt to an entirely new control mechanism.

    I use the “C” key for the mount’s special action ability and the “V” key for what used to be tied to the spacebar.

    The issue with your proposed solution is maybe players didn’t want the boost to go off at all and using it when they hit the ground is a waste.

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.