Roller Beetle Races Disappearing Boosts — Guild Wars 2 Forums

Roller Beetle Races Disappearing Boosts

Batman.7041Batman.7041 Member ✭✭
edited March 15, 2019 in Bugs: Game, Forum, Website

Hello everyone,

I would like to report a bug where when there is a roller beetle race (all of the 6 permanent ones) active in the map, (the ones that start with the blue rectangle box and allow everyone on the map to compete against each other for 3 racing medallions), if you start the time trial mode before the active map race is over, but try to continue PAST the point in time the active map race timer runs out, all of the remaining boost orbs Disappear and you have to restart the race if you want to get a good time in order to restore the boost orbs. To state this in another way for clarity, if you are trying to simply do the time trial race and do not want to do the active map race, and if you start while the map race is active and need to go beyond the duration of the map race, all the boost orbs consistently disappear mid time trial and you are forced to restart if you want to get a good time. This happens on all the permanent roller beetle races.

The solution to this would be to make the orbs not despawn while you are doing the time trial regardless of the status of the map races (that start with the blue rectangle box). (I have no idea what this entails technically, hopefully its not a headache). I have read the forums here and have seen people mention this same issue but as far as I can tell, no one has reverse engineered the reproducibility sequence for it so I thought I would share here. If this report already exists my bad. Please thumbs up this if you would like to see the reliability of roller beetle races improve and or if you have experienced this struggle as well.

TY Anet for everything you do and ty to all of those in the racing community for making it awesome :D I really hope to see the racing community grow!

Comments

  • Yes! A fix for this would be awesome! I run the races and the timed trials a lot, and it can be frustrating to have to restart a good run over, as I'm half way through!! Please and thank you Anet! :)

  • Ashantara.8731Ashantara.8731 Member ✭✭✭✭

    This has been the case since RB racing was introduced. I don't think it's a bug, it's just how the mechanic works.

  • Batman.7041Batman.7041 Member ✭✭

    @Ashantara.8731 said:
    This has been the case since RB racing was introduced. I don't think it's a bug, it's just how the mechanic works.

    Yeah this is the way it has come out in the beginning, but either way, this makes zero sense. There is no logical player workflow design reason why allowing players to start a time trial race when the game knows that the boosts will not be there when the map race resets thereby affecting the time trail races is a good idea. People get half way, maybe even most of the way done on a longer race and the boosts that are critical in some areas will be gone, ruining your time and making you start all over again. The boosts just need to not disappear ultimately. You should be able to start a time trial whenever you want, ignoring a map race altogether and be unaffected by the start/stop times of a map race. Hopefully it can be fixed at some point. :D

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.