Jump to content
  • Sign Up

Preview Window Issue - Gem Store and Hero Panel

Recommended Posts

I opened the Gem Store today and wanted to preview the new mounts.  The Preview Window is not centered in its "window". It acts this way for previewing capes and gliders as well. Its also happening on the Hero Panel. Is this a known issue for the DX11 setting in the graphics options? I have turned that on recently, but I did not notice this happening until today.


I wanted to attach screenshots, but I do not have that option in the editor.

  • Haha 1
Link to comment
Share on other sites

  • 2 months later...

Actually I am experiencing the same problem.


When opening the "Hero" dialog (e.g. equipment) then I see the player model slightly diplaced. Sometimes it is not showing at all, because the character seems to be places in the upper left corner. Believe me or not... When I drag the window to the upper left the character model appears again. This is so weird that I am starting to like it 😄 But seriously, when previewing colors and so on, this is not cool at all.


The only thing that changed in the last days was a Windows update (KB5017308), but I really cannot say if this had an direct impact. The problem occured first yesterday and I was playing with the update before without problems.

Then what I changes was the "use DirectX9 (Deprecated)" setting. Yes... just to see whats happening. Then after that it occured (I think, because I have not recognized it directly after it)


I made a short video to show it:


What I will do next is to try out the repair mode of the client.

Link to comment
Share on other sites

So the repair option


did not help in my case.


I will open a support ticket for that. This is really weird. Otherwise I am stuck with DirectX9, and furthermore in DirectX9 it is not that bad, but still the character model seems to be slightly displaced.


Also adding to the discussion:

Current Graphics drivers 516.94 (nvidia)

GW2 client 134.370


Link to comment
Share on other sites

At least in my case the problem is not occuring when turning off "DPI scaling" (right under the DirectX9 option).

But in my case this is not a solution, because I am at a 4K display (3840x2160) and the UI becomes tiny in that case.

I have opened a support ticket, let's see if this problem is already known.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...