Jump to content
  • Sign Up

[RESOLVED-PEBCAK ERROR] Progress blocked on POF Forgotten Debris Achievement


Recommended Posts

Excelsior!

I was trying to finish off the Forgotten Debris Achievement in Elon Riverlands earlier this week, and while I collected the Arid Gladefields Pool debris, it did not register for the achievement.

Thinking it might have been a bit of lag, or something getting mixed up when I got barracuda'd before finishing the first "cast" to collect the debris, I shrugged it off and finished the other handful I still needed. I tried again the next day, and once again collected the debris, but it still didn't register. I tried again on another character, which also failed, so I sent an in-game bug report. Since then, I've tried again on both characters, one by leaving it in the map and trying shortly after reset, the other after mapping about Tyria like a gadfly before returning. Still no joy.

Has anyone else encountered this, and if so, have you found a solution?

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...