Jump to content
  • Sign Up

Thief preparation traps failing to trigger

Recommended Posts

When using any of the preparations on thief I've been noticing that they don't always place the skill. Meaning that you press it and you assume it worked and then when you go to activate it, it fails. Thus the skill goes on cooldown with nothing happening. Initially, I thought it had something to do with the skill not placing the indicator and that if it doesn't place, it won't trigger. But, even when the skill glitches that way it sometimes still will function correctly. In total it seems there is a bug with the placing and activating preparations.

Link to comment
Share on other sites

Seal area when placed and it actually works only barely stops people entering or exiting. An example is heartseeker spammers can still get in or out.

What's worse is on interior traits or rubes o my proc 1 time...example is back to back HS spam only applies 1 or 2 Pulmonary Impacts as where it should apply them all per interupt. Both need to be addressed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...