Jump to content
  • Sign Up

API Sunset/No Longer Supported?

Recommended Posts

My partner and I have been playing the game for a little under two months now, and the API hasn't worked once on any tool or site we've tried the entire time. Multiple regenerations/deletions, permission combinations, and tools.  Not a single site or tool is able to retrieve anything, returning some flavor of "invalid API key".

I made the mistake of engaging support and was rapidly told to go to the forums to get help from other players for a server-side API issue. Not a great experience. I see multiple topics on the same issue all over the internet. Here there are no responses from devs when asked about it not working.

We've been holding off on purchasing anything since we're unsure if the game is on its way out or if a hard line against 3rd party tools is being taken for some reason. It would be appreciated to get some kind of update about this. No response usually means no one cares, which is a response in itself.

  • Confused 1
Link to comment
Share on other sites

I have 5 accounts. Each account has its own key and they all work.

As a test i created a new key for one of those account. The new key was different from the old one, but it still worked.

So i think this is NOT a "server-sided API issue".

Maybe your key is really invalid? The total length must be 72 characters (that's including the -). Anything else is wrong!

Edited by GODh.3892
Link to comment
Share on other sites

I'm glad your keys work. Mine do not and never have. Neither do my partner's.

As stated, I've regenerated several API keys now about a dozen times each over the course of several weeks, and my partner has also done the same thing on her account. We've created, deleted, and created again keys for full permissions and several combinations of various permissions. None have ever worked. Not once. So yes, I believe it is a "server-side API issue" given the number of times two players attempted to create new keys without success. They are all verified 72 characters, so that isn't the issue either.

All REST calls return a 400 error. They also time out, rather than returning any sort of error stating something about a malformed key, which is what I would expect if it were somehow my inability to copy/paste. The servers themselves are not returning any data with any of the dozen or so keys I've made on any tool I've tried. I have used multiple computers, multiple browsers on each, disabled plugins and shields, and tried multiple tools. Thus, server-side issue is the most likely.

Given that your keys are working, the servers are obviously not completely down, just degraded. There is an issue on the server side with SOME users' keys, though. I'm not the only one impacted, and it's hard to find any other troubleshooting steps to take to isolate a client side issue. No support is being given by the owners of said servers, either, so it's doubly frustrating.

  • Confused 1
Link to comment
Share on other sites

Use tokeninfo to confirm the key:


Then use one of the other APIs to confirm it actually works (this one requires the basic account permission):


Steam? I tried creating a key and tokeninfo confirms it, but everything else is 400 errors or it takes ~60s to respond with a 502 or 504 error. Definitely a server problem, so only ArenaNet can do anything.

Edited by Healix.5819
Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...