Jump to content
  • Sign Up

unable to purchase gem


Recommended Posts

@RoseofGilead.8907 said:

@"miku.3025" said:i think there is a glitch with trading post, i couldn't send gift, the option to send is greyed out.


The recipient name in your screenshot is your account name. Were you trying to send it to yourself as a gift? If so, you can't.

no its me trying to send to miku. you cant select yourself. it wont show in the list.it worked now btw. I think there was a glitch in the morning.Thanks for helping :D

Link to comment
Share on other sites

@"miku.3025" said:I tried a few times and received this msg, couldn't purchase gem with credit card for my daughter's account.attached a screenshot to show the msg.I purchase gem many times before with all my other accounts.Any advise?ThankssAoDIG2.jpg

I have encountered the same issue - whether by card or paypal I can not buy any Gems. This has been an issue for me for nigh on 2 days straight - submitted a ticket last night and 22hrs later not even a glimpse of a response or solution.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...