Jump to content
  • Sign Up

Removing multiple clients (32- and 64-bit) on Mac might solve some issues

Recommended Posts

Problem: Mac client unplayableThe 64-bit Mac client was essentially unplayable for me for various reasons, the two most important being:

  • extremely long load times for graphic elements every map change; and
  • skill usage displaying out of sync (an AoE circle would be actively on the ground, but no visual for it for 1-2 seconds.)

I had never removed the 32-bit client, and thus had two GW2 applications in my applications folder. Could these problems be related to issues my system is having accessing the appropriate files, or encountering interference from outdated files?

I understand why Anet created a process that allows the 64-bit Mac client to access files from the 32-bit installation. This means customers don’t have to follow directions for a more involved re-installation, or muck around in hidden directory structures. Ideally the new 64-bit client would have automated the reorganization and removal of obsolete files.

I decided to completely uninstall both the 32-bit & 64-bit client, and all associated files and folders, and then do a fresh install. (I had nothing to lose, since my Boot Camp set-up had gone wonky, and GW2 in Boot Camp can run very hot.)

This information isn’t new, I just couldn’t find it consolidated in one place, and in such a way as to make someone like me (with intermediate tech know-how) feel confident that I could interrupt an install and then replace a file stored “inside” an OS X application, something that was new to me, and works a little differently from Windows. So I thought I'd share my process.

Overall it should take about an hour, most of that is the time it takes to copy/move a huge 45gb dat file.


  • you’re not comfortable digging into your application files; and
  • you don’t know how to find library files — Apple hides these by default, so I’m not going to talk about that in this post, and if you don’t know how to find them, then you probably shouldn’t attempt this operation.

How-to —> summary:Basically, you’ll need to:

  1. Save two GW2 files: Gw2.dat and Local.dat
  2. Uninstall both the 32-bit & 64-bit versions completely
  3. Reinstall the 64-bit client
  4. Interrupt the install/download after 5-10 minutes
  5. Finally, place your two saved .dat files in the appropriate locations

Saving the Gw2.dat file means you won’t burn time & bandwidth re-downloading 45gb of data, which could take about 6 hours or longer depending on your internet plan/connection.

Saving the Local.dat file means you’ll preserve settings that are saved on the client side (most others are already saved with your account on the server side.)

How-to —> detail:1. Save two GW2 files: Gw2.dat and Local.dat

Save Gw2.dat from here:

  • /Applications/Guild Wars 2.app (32-bit version)
  • right-click the app and select “Show Package Contents”, then continue drilling down into the folder structure: Contents/Resources/transgaming/c_drive/GW2/Gw2.dat
  • Gw2.dat is a large file, approx. 45gb at this time
  • if it’s the 0 bytes version of Gw2.dat, you have the wrong one
  • save this file to a temporary location, such as the Desktop or a temporary folder of your choosing, though be aware that due to how application files may work on different OS versions, it may duplicate this file rather than just move it, so be ready for that if you have limited hard drive space

Save Local.dat from here:

  • /Users//Library/Application Support/Guild Wars 2/Local.dat
  • this file will be smaller, approx. 100mb

2. Uninstall both the 32-bit & 64-bit versions completely

Anet gives pretty clear instructions: Uninstalling Guild Wars 2 (https://help.guildwars2.com/hc/en-us/articles/360001707707-Uninstalling-Guild-Wars-2)

  • delete both GW2 applications
  • delete the entire Guild Wars 2 folder in the Application Support folder. A fresh version will be recreated during reinstallation
  • when you’re removing preference and cache files, “guildwars2” and “transgaming” are part of the files names — I found and removed two preferences and two cache files

3. Reinstall the 64-bit client

Download the Gw2Setup-64.dmg installer from Anet, only available in 64-bit for Mac.

Open the .dmg file, place Guild Wars 2 64-bit.app in your Applications folder, and open it to begin reinstallation.

4. Interrupt the install/download after 5-10 minutes

Quit the app to halt the download, and avoid re-installing the entire 45gb download. This gives the installer time to create the necessary directory structure and any necessary additional files, to make sure everything is in the right place.

5. Finally, place your two saved .dat files in the appropriate locations

Replace Gw2.dat here, replacing the partially downloaded .dat file:

  • /Applications/Guild Wars 2 64-bit.app
  • right-click the app and select “Show Package Contents”, then continue drilling down into the folder structure: Contents/Resources/Gw2.dat
  • you may have to copy/paste the .dat file, rather than moving/dragging the file

Replace Local.dat here:

  • /Users//Library/Application Support/Guild Wars 2/Local.dat

Success:This solved my two most important problems. I don’t know why. Is it really as simple as not having my Gw2.dat file not living within the 32-bit app? Or could an older file have been the cause, sinc approx. 25 files were deleted in this process, along with about the same number of empty placeholder folders? If anyone with more technical knowledge has any insights into why this worked, please explain or theorize.

I’d like to stress that if your Mac installation is working right now, don’t bother with this. This did not optimize the game for me in terms of better fps. I’m still running all graphics on their lowest settings. It just made the game “playable” in terms of the problems mentioned in my first paragraph, and if you’re experiencing the same or similar, this may be worth a try.

Link to comment
Share on other sites

HI,I have crashes with the 64 bit client from 10 to 40 minutes after each and every login, and the 32 bit login window vanished weeks ago.I own a Mac Mini half 2011, 8gb di RAM, i5, 2,3Ghz, El Capitan.The Mini works well with every app, except Guild Wars 2.After complete test steps with Game Support staff, they did not understand issue's cause.Etrecheck reports everything is in order, performance results are "good".The Mini complies minimum system requirements for the game.A series of tests runned by a certified Apple Technician did not find anything wrong with the computer.I don't know what to try next, so your post comes as fresh air.I do not have a double 32 and 64 bit 45gb file download, as I understand you had.Do you think your method may be good with this premises?

Link to comment
Share on other sites

@"Justin Time.7054" said:

Do you think your method may be good with this premises?

I was having performance issues, not crashes, so not sure this process would help your situation.

Also, if the problem is caused by the corruption of your Gw2.dat file, I believe this process preserves that exact same file.

I have no idea what’s causing your crash, but it’s worth ruling out corruption of the game client by running a repair (if you haven’t already). It’s an easy low-risk troubleshooting method (compared to downloading a fresh client.) It fixed my crash problem once.

Anet’s instructions —> https://help.guildwars2.com/hc/en-us/articles/201863008-Repairing-the-Game-Client

When copying/pasting into Terminal, make sure to modify the file path if your GW2 app is not in your Application folder.

Also, when running this repair on a Mac, Terminal does not give any feedback that it’s finished, so I just let it run for about two hours to make sure it does its thing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...