Jump to content
  • Sign Up

Stuck in loading screen after using "Teleport to Friend" item when accessing character

Recommended Posts

This incident had occured for not just once, but twice. The first time, I was teleporting to my friend who was in Desert Highlands while I'm in Crystal Oasis. I left the computer there in the loading screen and went to bed. The second day, my family member turned off the computer before I woke up, describing that it was still in the loading screen when they did it afterwards. I tried to enter the character again and it's still stuck there in the loading screen. I waited for another half an hour before finally deciding to screenshot it for technical support, only to finally have the game load right after I pressed the PrintScreen button. So I shrugged it off and continued playing.

I did test it again with my friend the second time with Desert Highlands to the Elon Riverlands, and it worked perfectly without any problem. We then decided to head for The Desolation afterwards. Only to have myself stuck in this screen even after leaving it overnight, pressing PrintScreen, and restarting my computer.BowuHB8.jpg

The problem had persisted for 2 days straight. With myself being disconnected ever so and often for being idle for too long in the meanwhile. I did retried to leave it there. Tested with my other characters which worked just fine whenever I access to them. So I really don't know why is this happening. If anyone had any idea, I plea for you to do offer some help.

Screenshot attempts made:3TlvMFL.png

Link to comment
Share on other sites

@"Inculpatus cedo.9234" said:You can try the Command Line Argument, -prefresetOr, you can contact the Tech CS Team via the 'Support' link above/below.


Good luck.

I do not think it is the client problem but the server problem anyway. Because like I stated, I can still access my other characters just fine.

Link to comment
Share on other sites

There is currently a problem with some patch servers that causes GW2 to get stuck while downloading files. If your game isn't fully patched, it'll download what it needs on the loading screen, which will cause it to get stuck loading when it can't complete the download.

If this is the problem, launch using:


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...