Feedback: Guild Wars 2 Mac 64-Bit Client - Page 19 — Guild Wars 2 Forums
Home

Feedback: Guild Wars 2 Mac 64-Bit Client

1131415161719>

Comments

  • So my sound issue was nothing to do with the game, its my kvm switch. Map movement is still nice and fast.

  • ...And I figured out why my map is so nice and fast. I have two mice plugged in, one MS USB wheel mouse (nice and fast map) and my Logitech G600 (slow map).

    The issue with the map scrolling and panning speed lies in the mouse polling speed setting. I used my Logitech software to set the mouse polling speed to 125 reports per second and voila, smooth maps movements on both mice! :)

  • Hi, when downloading the client I get about 53% past the playable threshold and then it just stops downloading and I've been stuck on 53% for about 4 hours now. Don't get me wrong, the game works and loads perfectly fine (a little slow when visiting major cities mind, but nothing too noticeable), but I'd quite like to fully install the game incase I do run into any issues. Anyone else had this? It just runs on a loop saying like 254,117 files left to download, and my internet speed is pretty decent. Any help would be appreciated :)

  • Launch Terminal, copy and paste below into the terminal and press 'enter'

    /Applications/Guild\ Wars\ 2\ 64-bit.app/Contents/MacOS/GuildWars2 -repair

    This assumes your GW2 installation in in Applications, adjust as required.

  • @Jacques.8170 said:
    Launch Terminal, copy and paste below into the terminal and press 'enter'

    /Applications/Guild\ Wars\ 2\ 64-bit.app/Contents/MacOS/GuildWars2 -repair

    This assumes your GW2 installation in in Applications, adjust as required.

    Thank you, I tried this but I got this major error:

  • Ah, I just realised I can't post photos :/ It was a big long error and it said it was a major error that would stop it from running, but it still runs anyway..

  • hello

    i use a 2017 macbook pro / upgraded to catalina and everything is downloaded 100% 64bit

    i used to be able to run this game just fine with autodetect settings

    it seems something changed somewhere down the line as the game keeps "chopping up" whenever i try to play it even at the lowest settings

    how do i fix this

    thanks

  • by the way sorry about the late "fix" to my reply but what i am refering to is the framerate

  • Aoi.8570Aoi.8570 Member ✭✭
    edited March 1, 2020

    I'm back to Guild Wars 2 after a break since last summer, and I don't know what changed, but I've never experienced such low FPS rate until now. I play on the LOWEST possible settings (everything LOW/turned off), even lowered resolution. 10 fps is the best I can get nowadays (while playing 2v2 arena...), even though 25-40fps was average before.

    Macbook Pro - Retina, late 2013. (obviously I could blame it on computer, because it's not the newest model and "Mac(book)s are not for games!", but the computer itself coudn't get that much worse in 6 months).

    Edit: Few hours later, tried every possible option to increase the performance, but the game is basically unplayable. Seriously, I've no idea what game devs have done lately, but I can't do anything: explore maps, do events, play 2v2 PvP. Moreover, game started to crash very often.

  • ^ this is what i meant thank you

  • So I am having this issue since 3 days ago, it kept on saying serious error messaged every time i clicked on the gw2 64bit launcher on Mac. Currently its version is at 10.15.3 for MacOS. I tried to repair it by using the terminal but it doesn't work at all, i spammed the terminal and it is the same. Is there anything else that could help me able to play it on my Macbook Pro? Thank you.

  • Hi guys! PLEASE help me I using
    MacBook Pro 16'' (16-inch, 2019)
    2,4 GHz 8‑ядерный процессор Intel Core i9
    32 ГБ 2667 MHz DDR4
    AMD Radeon Pro 5500M 8 ГБ
    !
    Tell me please WHY I have just 40 FPS and some times less even! and I using lowest settings !

  • Same problem with Macbook Pro 16" 2019
    2,3GHz 8-core intel core i9
    16GB Ram 2667 MHz DDR4
    AMD Radeon Pro 5500M 4GB
    It runs low FPS even on lowest settings. It never runs smoothly?

  • Just updated my iMac to Catalina 10.15.4 (which is only few months old) And now GW2 will not launch, all it does is bounce in the dock. Have to force Quit.
    Uninstalled and reinstalled game still no go.

  • papsu.6094papsu.6094 Member ✭✭
    edited March 25, 2020

    I had the same problem with Catalina 10.15.4. Game wouldn't start. It just bounced on the dock.

    EDIT: From the terminal, forcing some cleaning seems to have fixed it.
    __
    cd /Applications/Guild Wars 2 64-bit.app/Contents/MacOS
    rm CoherentUI_Host
    cd ~/Library/Application\ Support/
    rm -rf Guild\ Wars\ 2
    __

    Try that and see if it works for you. Worked for me.

  • I too had the problem, the GW2 Launcher would not run after upgrading to 10.15.4. However, running the repair tool as described here completely fixed the problem. Everything works again, after the repair.

  • Sometimes it's helpful to let XProtect finish it's job before randomly killing processes :D
    Watch task list when icons are bouncing after an update ...

  • I redownloaded GW2 and it seems to be working... it is still updating.

    The bug may have to do with a security feature in MacOS.

  • papsu.6094papsu.6094 Member ✭✭

    @Snobran.3652 said:
    Sometimes it's helpful to let XProtect finish it's job before randomly killing processes :D
    Watch task list when icons are bouncing after an update ...

    Thanks for that. XProtect seems to be stuck. Killing it in Activity monitor relaunches it. But this also allows the game client to load. Is this a problem on Apple's side?

  • @papsu.6094 said:

    @Snobran.3652 said:
    Sometimes it's helpful to let XProtect finish it's job before randomly killing processes :D
    Watch task list when icons are bouncing after an update ...

    Thanks for that. XProtect seems to be stuck. Killing it in Activity monitor relaunches it. But this also allows the game client to load. Is this a problem on Apple's side?

    Dunno. I also tried let it finish and game client loads either. But waiting each time 15m for XProtect seems not reasonable either.
    I think, Apple could care more for GW2 - but also could Arenanet care more for macOS users. When both sides don't care - gamers on macOS are rare for sure.

  • It’s not Arenanets fault. The new MacOS just came out. You can’t expect them to make a fix when they don’t know a problem exists yet. I deleted my app and redownloaded gw2 and its working

  • @Wysardi.9302 said:
    It’s not Arenanets fault. The new MacOS just came out. You can’t expect them to make a fix when they don’t know a problem exists yet.

    Understood. There is no beta-program for interested users and there is no company/developer contact for early testings.
    Good to know :pensive:

    For those who want to check whether their XProtect is up-to-date: https://eclecticlight.co/lockrattler-systhist/ does check this and other components.

  • Recently I have also been suffering from the low FPS issue with MBP 16'' 2019.
    2.6 GHZ i7, 16GB RAM
    5300M Radeon Pro (performance equivalent to GTX 1650)
    I used to play GW2 in bootcamp (Windows 10) since in 2019 the Mac client didn't work at all with 16" MBP. After installing d912pxy I was playing on best appearance (everything maxed out) with 30 FPS being the absolute minimum I could get. Average was 40, in "easier" environments even 50. It was amazing, perfectly smooth and absolutely breathtaking experience on this laptop!!! I don't know what changed recently (I updated the game a week ago, been playing on my desktop since december), but now in Windows it's only playable without d912pxy and far from enjoyable. I get a max. of 30 FPS with best appearance, but I suffer from 15-20 FPS lag spikes when I turn around too quickly/mount up etc. (similar issue like in 2019, a bit milder). VSync doesn't help, makes it even worse. Using d912pxy removes these lag spikes (like in 2019) but now I only get 15-25 FPS so that's a no-go as well.
    Mac client works now but it's only playable with lowest settings (even though autodetect sets it mid/high).
    Please, make at least the windows version enjoyable again. I believe it's a GPU optimisation problem since changing the CPU-intensive settings has no effect on FPS. Now I'm stuck playing with low-end details (in windows without d912pxy or in mac), which give me 50-60 FPS and spikes of 20-30 FPS. A pity with this setup :(

  • papsu.6094papsu.6094 Member ✭✭

    @Snobran.3652 said:

    @Wysardi.9302 said:
    It’s not Arenanets fault. The new MacOS just came out. You can’t expect them to make a fix when they don’t know a problem exists yet.

    Understood. There is no beta-program for interested users and there is no company/developer contact for early testings.
    Good to know :pensive:

    For those who want to check whether their XProtect is up-to-date: https://eclecticlight.co/lockrattler-systhist/ does check this and other components.

    While you are being sarcastic about Apple Developer & Beta programs, ArenaNet should invest some time and effort in testing the game with upcoming software releases. -- https://beta.apple.com/sp/betaprogram/

    Thanks for the link for checking software update. I installed the command line tool.

  • I use to play this game in 2015... and now, with this virus stuff going on, I thought it was a good ideia to try it back once again. But guess whats. IT IS IMPOSSIBLE to download the game client for Mac. The download starts and get so slow, that shows it's going to take me 80 day to get it! LOL Does anyone knows how to fix this?

  • It is impossible to download gw2 client from s3.amazonaws.com - I CAN'T connect with this site to start the download.
    Any tips on how to download this gw2 client?

  • I really like Guild Wars 2, but the 64-bit macOS client is really a pain in the kitten.

    Performance is pretty poor, considering running this on an almost maxed-out MacBook Pro 2018 using an Vega 64 eGPU.
    And what's really strange about it, is that even if you turn all the graphics down to the very minimum, the performance gain is so very little, that you can just keep a rather high setting (then at least it looks kinda good).

    With the latest Catalina 10.15.4 (supplemental update) things got even worse, as the client just crashes randomly.
    This is really really annoying as I'm right in the middle of a story quest line and have to like play the parts 3 times each, to get get one lucky shot, where the client does not crash.

    Pleeeeeaaaaase ArenaNet invest some time and money and fix the macOS client.

  • I have a brand new Mac with gen10 i7, exactly the same config as in a Win machine I got.
    Windows: smooth at medium settings
    Mac: barely playable at ultra low settings.

    I looked for the config file as they mentioned on the Internet for adding vRAM to the program, the file seems not even be there..

    What's happening? Why does a lesser OS like Windows give tons of more frames compared to a better UNIX like OS?

    Stange...

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭
    edited April 17, 2020

    @FiveBugs.8503 said:
    I have a brand new Mac with gen10 i7, exactly the same config as in a Win machine I got.
    Windows: smooth at medium settings
    Mac: barely playable at ultra low settings.

    I looked for the config file as they mentioned on the Internet for adding vRAM to the program, the file seems not even be there..

    What's happening? Why does a lesser OS like Windows give tons of more frames compared to a better UNIX like OS?

    Stange...

    The game uses OpenGL on macOS which is the single biggest performance killer here. It is no secret that for some time OpenGL is in a bad state on macOS and unfortunately ANet opted to use that over the more advanced Metal API. Aside from this, the game is also better optimized on Windows.

    Currently your alternatives are 2: Setup Bootcamp with Win10 just for the game or install a modern Linux distro (the latter might be a bit tricky).

  • Aran.9374Aran.9374 Member ✭✭

    I can't get more than 7fps on my Mac with all settings on low. GW2 is no fun anymore and it sucks. No answers from Anet or Apple.

  • @ArmoredVehicle.2849 said:

    @FiveBugs.8503 said:
    I have a brand new Mac with gen10 i7, exactly the same config as in a Win machine I got.
    Windows: smooth at medium settings
    Mac: barely playable at ultra low settings.

    I looked for the config file as they mentioned on the Internet for adding vRAM to the program, the file seems not even be there..

    What's happening? Why does a lesser OS like Windows give tons of more frames compared to a better UNIX like OS?

    Stange...

    The game uses OpenGL on macOS which is the single biggest performance killer here. It is no secret that for some time OpenGL is in a bad state on macOS and unfortunately ANet opted to use that over the more advanced Metal API. Aside from this, the game is also better optimized on Windows.

    Currently your alternatives are 2: Setup Bootcamp with Win10 just for the game or install a modern Linux distro (the latter might be a bit tricky).

    I really tried everything... and for me* the native macOS 64-bit client is still the best solution (as hard as it sounds...)
    1. Bootcamp using Windows 10: Doesn't really support eGPU, there are hack-arounds on the web, but I didn't get it working at all. And anyway all those hack-arounds seem pretty fragile (concerning OS updates, etc.).
    2. Parallels Desktop 15 using Windows 10: Despite advertising to be optimised for gaming, the performance is still worse compared to the native macOS client
    3. Wine: No macOS Catalina (64-bit) support yet
    4. CodeWeavers (commercial wine version?): Performance also worse compared to the native client
    What else could we try? :-)
    Buying a Windows PC? ;-)

    *MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports), i5 (2.3GHz), 16 GB RAM, Radeon Vega 64 8GB (inside Razor Core X eGPU housing)

    For comparison: Playing Heroes of the Storm in 4K at pretty maxed out settings runs at around 100fps.
    Guild Wars 2 doesn't really care much about the settings, it always sucks in performance. At least using 1080p, and turning down shadows and/or reflections were really the only settings that very very slightly improved the performance. The FPS really are going up and down, but there is definitely visible stutter at around 5-15fps in cities or so, and I think I never really get more than 30-40fps (very very best case). Especially when entering a new zone (e.g. teleport) in the beginning it's so sluggish, and almost unplayable. -.-

  • dark.2037dark.2037 Member
    edited April 19, 2020
    1. VMWare Fusion 11.5 using Windows 10: As long as watching in one direction it's kinda ok, but when turning around, fps drop to unplayable low rates.

    Here's the best tradeoff between performance and still looking good:
    Settings

  • Hi there!
    I'm a Macbook Pro user Early 2015, OS Mojave (10.14.6)
    I have been playing for a month more less with absolutely no problem. Since Yesterday (April 25) I play and suddenly the game freezes and the only way out I have is to manually restart my Mac. And it happens constantly. I tried Repairing the client, and it hasn't changed a thing.
    Can anyone help me?
    I even bought PoT yesterday and I would love to be able to do play.... this is absurd....
    Thank you very much! :)

  • lilins.7103lilins.7103 Member ✭✭

    So ArenaNet is not even thinking of MoltenGL? it’s really annoying to need to reboot to Windows to have about more than 2x performance.

  • ArmoredVehicle.2849ArmoredVehicle.2849 Member ✭✭✭

    @lilins.7103 said:
    So ArenaNet is not even thinking of MoltenGL? it’s really annoying to need to reboot to Windows to have about more than 2x performance.

    Apparently MoltenGL only translates OpenGL ES which is a bit different than the "desktop" OpenGL. I think I get your point, by using something similar, it might save ANet a lot of hassle from starting from scratch to switch to Metal. TBH I'd rather have them just to do the latter and be done once and for all with the low performance issue.

  • So, any news from ANet regarding the Mac OS client performance issues on MBP 16?

  • Emberstone.2904Emberstone.2904 Member ✭✭✭

    @Telnair.2158 said:
    So, any news from ANet regarding the Mac OS client performance issues on MBP 16?

    I wouldn't hold your breath. If they aren't switching from Dx9 on their main platform (Windows), they probably aren't updating from OpenGL.

    I'd love to play under MacOS on my laptop because of how hot the thing gets under Windows, but we probably won't ever have a real choice unless you're okay with 30 FPS on subsampled graphics.

  • Ok just getting back in to [email protected] but I can't get it to run on my mack. I downloaded the 64bit client, it still won't load. How do I fix this.

  • @papsu.6094 said:
    I had the same problem with Catalina 10.15.4. Game wouldn't start. It just bounced on the dock.

    EDIT: From the terminal, forcing some cleaning seems to have fixed it.
    __
    cd /Applications/Guild Wars 2 64-bit.app/Contents/MacOS
    rm CoherentUI_Host
    cd ~/Library/Application\ Support/
    rm -rf Guild\ Wars\ 2
    __

    Try that and see if it works for you. Worked for me.

    Hi. Wanted to say thanks to @papsu.6049

    This worked for me.

    I had just updated to Catalina 10.15.4 last night. Suddenly GW2 was just bouncing on the dock and doing nothing. I tried the repair, got a serious error crash and it wouldn't load.

    I couldn't use your commands pasted into Terminal, but was able to find the Folder and COHERENTUI_HOST file for deletion.

    After deleting, the client is running.

    Big Thanks!

  • This isn't a perfect solution but I was able to improve my fps by launching the 64-bit client from the command line with an extra argument:

    /Applications/Guild\ Wars\ 2\ 64-bit.app/Contents/MacOS/GuildWars2 -forwardrender

    Source: https://wiki.guildwars2.com/wiki/Command_line_arguments

  • Tseng.3761Tseng.3761 Member ✭✭

    @ArmoredVehicle.2849 said:
    The game uses OpenGL on macOS which is the single biggest performance killer here. It is no secret that for some time OpenGL is in a bad state on macOS and unfortunately ANet opted to use that over the more advanced Metal API. Aside from this, the game is also better optimized on Windows.

    Any idea on why OpenGL is such a performance killer? Have seen multiple comparisons of DX to OpenGL with them being pretty similar in terms of their demand and performance.

  • omg it really sucks on my new MBP 16, i cant even move.
    i dont want to bootcamp, please help me.
    it seems gamers on Mac are neglected. We paid, we should get an at least soomth game!

  • Are there any plans to support MacOS after the transition to ARM/Apple Silicon?

  • On my version the first line became:

    cd /Applications/Guild\ Wars\ 2\ 64-bit.app/Contents/MacOS/

    @Altrax.4069 said:

    @papsu.6094 said:
    I had the same problem with Catalina 10.15.4. Game wouldn't start. It just bounced on the dock.

    EDIT: From the terminal, forcing some cleaning seems to have fixed it.
    __
    cd /Applications/Guild Wars 2 64-bit.app/Contents/MacOS
    rm CoherentUI_Host
    cd ~/Library/Application\ Support/
    rm -rf Guild\ Wars\ 2
    __

  • Talek.6795Talek.6795 Member ✭✭

    @PadmaPhala.1824 said:
    Are there any plans to support MacOS after the transition to ARM/Apple Silicon?

    I hope to hear some good news from Anet regarding this question

  • Tseng.3761Tseng.3761 Member ✭✭

    @Talek.6795 said:

    @PadmaPhala.1824 said:
    Are there any plans to support MacOS after the transition to ARM/Apple Silicon?

    I hope to hear some good news from Anet regarding this question

    For real, maybe they redo their entire mac client with the Metal API for the new expansion. Highly doubt its worth the time and money investment from them, but one can dream.

  • Talek.6795Talek.6795 Member ✭✭

    @Tseng.3761 said:

    @Talek.6795 said:

    @PadmaPhala.1824 said:
    Are there any plans to support MacOS after the transition to ARM/Apple Silicon?

    I hope to hear some good news from Anet regarding this question

    For real, maybe they redo their entire mac client with the Metal API for the new expansion. Highly doubt its worth the time and money investment from them, but one can dream.

    I do agree! ;)

  • @Aoi.8570 said:
    I'm back to Guild Wars 2 after a break since last summer, and I don't know what changed, but I've never experienced such low FPS rate until now. I play on the LOWEST possible settings (everything LOW/turned off), even lowered resolution. 10 fps is the best I can get nowadays (while playing 2v2 arena...), even though 25-40fps was average before.

    Macbook Pro - Retina, late 2013. (obviously I could blame it on computer, because it's not the newest model and "Mac(book)s are not for games!", but the computer itself coudn't get that much worse in 6 months).

    Edit: Few hours later, tried every possible option to increase the performance, but the game is basically unplayable. Seriously, I've no idea what game devs have done lately, but I can't do anything: explore maps, do events, play 2v2 PvP. Moreover, game started to crash very often.

    same here. trying it on my mbp 2019 (i7, 16gb ram, ssd, dedicated gpu) AND my monster hackintosh (10900k, 5700xt, 64gb ram, ssd, etc). horrible performance, totally unplayable!. wow on the other hand, 60fps on high (ultra on hackintosh) in crowded areas

    such a shame, devs please implement metal or do something

  • @FiveBugs.8503 said:
    I have a brand new Mac with gen10 i7, exactly the same config as in a Win machine I got.
    Windows: smooth at medium settings
    Mac: barely playable at ultra low settings.

    I looked for the config file as they mentioned on the Internet for adding vRAM to the program, the file seems not even be there..

    What's happening? Why does a lesser OS like Windows give tons of more frames compared to a better UNIX like OS?

    Stange...

    devs don't care about us, that's why

    @Aran.9374 said:
    I can't get more than 7fps on my Mac with all settings on low. GW2 is no fun anymore and it sucks. No answers from Anet or Apple.

    Apple have no control over lazy devs

  • itinerant.5081itinerant.5081 Member
    edited August 25, 2020

    Hi guys!

    I have been using the GW2 Mac OS Client on and off. There has been a severe performance hit from Path of Fire launch to the release of the last few LW episodes. That being said I think there are a few things you can do to improve performance whilst using the existing Mac OS Client.

    This is off the top of my head and you will need to google the rest of the steps.

    1. Lock the DPS count and use vsync to 'cap' the frames being rendered, on a small screeen I can make do with 30fps cap.
    2. Reduce shadows to none or the lowest setting.
    3. Reduce the model count.
    4. Reduce model quality.
    5. Reduce textures.
    6. Reduce most post processing.

    ** Special command, try to launch the GW2 Mac OS client from the command line (Terminal) with the -forwardrenderer prompt.

    With all the above optimizations you should be able to have 19-20 fps in core Tyria (On a Macbook Air 2018 or similar machine) and 10-15 fps in HoT maps. This is only for solo play and not for metas. The problem with the existing GW2 client is that it is not using metal and the performance is atrocious. I have since moved on to using a Windows machine to play GW2.

    Cheer!