Jump to content
  • Sign Up

Story Achievements broken?

Recommended Posts



I tried to do some of the new "Flame and Frost" achievements, but cannot see a way to do them:

- Investigative Study 1: Cannot get the 3 information sources from the Command Core (Black Citadel). In the first instance (the Command Core) I cannot reach the tables with the notes (will be thrown back on this "bridge" thing). Later there is nothing on the tables.

- Secret Contact: These hidden messages, 6 in Diessa (no problem) and 6 in Wayfarer Hills. I cannot find the messages in Wayfarer Hills. Talking to that NPC won't work, I even got a message that there should be more hidden messages on that map, but on the given locations are none. Was in the correct part of story (I guess). 

- Lost and found: When will these items be visible? Searched at the possible locations for these, but nothing there (used even a guide from Guildjen for that - and the messages above).


Or did I something wrong?


Link to comment
Share on other sites

On 4/20/2022 at 5:31 PM, LuRkEr.9462 said:

The wiki has how to for all of those. I just did them so atleast worked for me. 

https://wiki.guildwars2.com/wiki/Investigative_Study_1 (Note have to wait for a minute for guard to let you pass)




How long do you have to wait for the guard? I waited for several minutes and the guard isn't leaving or let me pass. I restarted the episode three times but no luck.


To answer my own question: Many minutes. After at least five minutes the guard finally let me pass.

Edited by Rose Solane.1027
Found the answer
Link to comment
Share on other sites

For the guard you just have to tell them that you are the commander (in the dialoque that pops up) - then they will let you pass. Selecting the other option won't work.

See here: https://wiki.guildwars2.com/wiki/New_Friends,_New_Enemies#The_Command_Core

For the dialogue with the "Quorum Guard" select "Not even for Pact Commander <Character name>?"

Edit: Tried this again with my next char that I want to send through the whole S1 story: It actually works to even skip the first dialogue cutscene (then they will still talk while you are out of custcene) and to run up to the guard until it pushes you back - which then automatically initiates the dialogue as mentioned above. Then selecting that you are the pact commanders - will let you pass.

If for some reason the dialogue does not pop up or you have to wait ... it would be a bug - no clue as to what conditions lead to getting the bug. Since not everyone seems to get it. And some can't pass the guard at all while others have to wait some time. Weird.

Edit2: If I had to take a guess ... maybe characters that do not have completed the core personal story yet are not recognized as "pact commanders" by this story step - having to wait until the meeting ends to proceed past the guard. Therefore waiting time?

Edit3: Old version apparently really seems to have given different dialogue options based on core personal story progress. "Forging the pact" story step was required to immediately be able to progress the guard - getting the dialogue option I mentioned above. (Old wiki entry from the release 2013 for reference: https://wiki.guildwars2.com/wiki/Rox:_Critical_Mission )

Edited by Luthan.5236
  • Confused 1
Link to comment
Share on other sites

  • 3 months later...
On 4/20/2022 at 1:39 PM, Inculpatus cedo.9234 said:

I didn't have to wait for the guard to let me pass, but I did have to redo the story to enter the story instance to find the letters.  They are not there when entering the instance outside of the story.  (Which didn't seem clear to me from the hints/instructions in-game.) 

I'm afraid this is what I'm going to have to do, too.  For some reason, after the guard let me pass during "New Friends, New Enemies" the objects were not clickable (the wiki says they don't have nameplates, so I clicked every item).  I spoke to all the NPCs in the command core and tried to click on the objects again with no luck.  Eventually I left the instance to progress the story thinking that's what I needed to do before the items were available, which was wrong.

Edited by ZioGio.9102
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...