Jump to content
  • Sign Up

Salvation (Greatsword) recipe not working

Recommended Posts

The new MF recipe for Salvation does not seem to be working. I put in an Exotic Greatsword, 100 Elonian Wine, 1 Ectoplasmic Stone and 1 Anthology of Heroes, the Forge says it is a valid recipe, I click Forge and the ingredients fly in, and... nothing else happens. The ingredients aren't consumed and the Forge gives me nothing back. I've tried the recipe using the Mordrem Greatblade, the Dragonsblood Greatsword, and a random level 70 Exotic Greatsword I bought off the TP and all of them have the same issue. Is anyone else experiencing this?

Link to comment
Share on other sites

OK, I just tried using the Mystic Forge in LA and it DID work. That is SO weird. I'd been trying both the Mystic Forge in the Mistlock Sanctuary and via the Mystic Forge Conduit device and both weren't working. If anyone else is experiencing this issue, try going to LA and using the MF there to see if it works for you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...