Jump to content
  • Sign Up

Mystic Forge recipe not valid ?

Recommended Posts

Hi, so I was trying to get my hands on some gold and I have come upone the following recipe : https://gw2.fandom.com/ja/wiki/Cured_Hardened_Leather_Square,which can be found on the wiki too : https://wiki.guildwars2.com/wiki/Cured_Hardened_Leather_SquareProblem is that after I have tried to follow the recipe ,whenever I add the "Cured Thick Leather Squares" I am unable after to add "Hardened Leather Section" and vice versaI have tried asking around and didn't get any response,can someone offer me some help regarding this problem ?(I have stacked myself with lots of cured thick leather squares and can't do nothing with them rn )

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...