Jump to content
  • Sign Up

[BUG] Aetherblade Shenanigans impossible to complete

Recommended Posts

19 hours ago, wondermuffin.9680 said:

I just completed this event, and it was not bugged. Maybe they fixed it? Or did I get lucky?


@Tidus Van Kennedy.8320It spawns quite south at Jaya Bluffs, behind the monastery. Here's a screenshot of where it is: https://ibb.co/QvCJYZq

It seems the same event occurs in at least 3 places in Jaya Bluffs, but only the one in the south that you showed gives credit for the achievement.

  • Like 3
Link to comment
Share on other sites

Yeah, I checked the Wiki earlier and saw that someone had updated it. Previously the Wiki was suggesting the Aetherblade Ambush that takes place near the Eastern crash site, which was incorrect. I tried the Jade Mech reinforcement event and it did indeed work. Mystery solved!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...