Jump to content
  • Sign Up

Feedback: New mounts


Recommended Posts

The Iceflow jackal is amazing, but the ice-shard trail that happens when you run (the one tied to all ice-mounts) is using the bottom-right dye slot. This means it will always be extra dark, unless you make the ice blocks permafrost/frostbite. I suggest that the ice shard trail is moved to either top-right dye slot or bottom-left dye slot, that way it's easier to make the shards white without having to mess with the ice blocks colour. Right now even dying the ice blocks into some natural, icy-blue colour makes the icy trail effect dark-grey and almost invisible.

Link to comment
Share on other sites

Just like the first batch, I liked a lot of these skins, so it was no hardship to buy a bunch of them to take advantage of the reduced price for buying 5 at once. The Primus Beta skimmer skin was my standout favorite but I also ended up using the Iceflow jackal, Primeval bunny, and Exalted Sky Sentry griffon. They all look great!

Link to comment
Share on other sites

Except on the whiskers, I don't seem to be getting the lightning effects on my Sargol Thunderbunny. Would that be something to do with my settings, or a glitch, like the one they just fixed on the branded Jackal?

These mount skins are beautiful, out of all 15 there are so many that are fabulous, and only a few I don't care for at all (and I'm sure those skins have their fans, too.)

Link to comment
Share on other sites

@"Cragga the Eighty Third.6015" said:Except on the whiskers, I don't seem to be getting the lightning effects on my Sargol Thunderbunny. Would that be something to do with my settings, or a glitch, like the one they just fixed on the branded Jackal?

These mount skins are beautiful, out of all 15 there are so many that are fabulous, and only a few I don't care for at all (and I'm sure those skins have their fans, too.)

probably some of the settings. maybe animation?

Link to comment
Share on other sites

@Sublimatio.6981 said:

@"Cragga the Eighty Third.6015" said:Except on the whiskers, I don't seem to be getting the lightning effects on my Sargol Thunderbunny. Would that be something to do with my settings, or a glitch, like the one they just fixed on the branded Jackal?

These mount skins are beautiful, out of all 15 there are so many that are fabulous, and only a few I don't care for at all (and I'm sure those skins have their fans, too.)

probably some of the settings. maybe animation?

Yep, setting animation higher gives me lightning. ^^ Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...