Game alt-tabbing or flashing desktop [merged] - Page 3 — Guild Wars 2 Forums

Game alt-tabbing or flashing desktop [merged]

1356710

Comments

  • AnClar.1304AnClar.1304 Member ✭✭
    edited May 7, 2018

    Another issue that may or may not be related to the flash to desktop/alt-tab problem also started for me after the April W10 update, and there is a thread about it as well https://en-forum.guildwars2.com/discussion/38922/log-in-click-play-nothing-happens#latest . That is the "disappearing client" issue. Start client, log in, click PLAY, and hey-presto, the client just flat out disappears without a trace. I can restart the client, and the exact same thing happens...no warning, no error messages, just poof...gone. The only way to fix the issue that I've found is to reboot the computer. I've added the disappearing client issue to my support ticket about the flash to desktop problem.

    Just for the record, the flash to desktop issue doesn't happen when I run in Windowed Fullscreen mode, only in Fullscreen mode.

  • Razoozle.2176Razoozle.2176 Member ✭✭

    Does this only happen with GW2 or does it happen with any game? I had a similar issue before where anything full screened or even just windowed mode would lose focus and tab out... I had to reinstall windows to fix the issue, I was thinking it was some sort of malware because it happened twice in quick successions every few hours, causing my cursor to use the loading animation...

  • Amhiel.6195Amhiel.6195 Member ✭✭

    Only happening on this game in Fullscreen only. Windowed Fullscreen is fine. Completely disrupts discord audio when it flashes to desktop during map change or launch. W.o.W. , RIFT, and SWTOR are fine. No issues with these so it's definitely this game. Ran DDU, Reinstalled graphics drivers, repaired game client, and made sure Windows 10 is updated along with my processor. All are fine on my end. please fix soo, it's killing my Discord convo

  • @Amhiel.6195 said:
    Only happening on this game in Fullscreen only. Windowed Fullscreen is fine. Completely disrupts discord audio when it flashes to desktop during map change or launch. W.o.W. , RIFT, and SWTOR are fine. No issues with these so it's definitely this game. Ran DDU, Reinstalled graphics drivers, repaired game client, and made sure Windows 10 is updated along with my processor. All are fine on my end. please fix soo, it's killing my Discord convo

    waves Assuming this is the guildy I was talking to...
    I run windowed, have the same graphics card he does (nvidia gtx1070), and haven't experienced this problem.

  • brokenrabbit.6538brokenrabbit.6538 Member
    edited May 8, 2018

    I am having this problem as well since installing the Windows 10 Spring Update. As described above: flashing to desktop upon logging in with a character and also when switching maps. Though I noticed it does not do it when switching between your home instance and Divinity's Reach.

    Radeon RX 480 so yes this affects AMD cards as well. Radeon drivers are dated 4/25/2018 (Released 4/30/2018). [email protected]

  • Heather.4823Heather.4823 Member ✭✭
    edited May 8, 2018

    @Gaile Gray.6029 said:
    I'll go and find and round up all the threads and leave them here in Account and Technical Support.

    My thread has been merged with a totally different issue of flashing once per login.
    All the people that were replying to mine said they had the same which was flashing to desktop on ALL loading screens only since the April windows 10 update.

    The post it has been merged with is flashing to desktop once per login back from in January. Not the same thing at all...
    Please can you unmerge from this unrelated January thread.

    Also surely this is a bug as so many people replied with the same problem. This is also before the April win 10 update is pushed to all users.

  • Heather.4823Heather.4823 Member ✭✭

    @holodoc.5748 said:

    @Gaile Gray.6029 said:
    Is anyone else experiencing this issue? I've not heard of it at all, nor are we seeing it on social media.

    Windows 10 April update (build 1803)

    Glitch happens on every map change except when entering and exiting home instances.

    Also initial display of character selection screen after login is much longer than before (approximately ten seconds compared to a couple before).

    Yup this is it. Every loading screen gets this and I agree the initial character screen is much longer than before.

    Only got it right after April Windows 10 update.

    Lots of people have this now so maybe you can acknowledge this problem Abet

  • AndyS.6079AndyS.6079 Member

    @holodoc.5748 said:

    Windows 10 April update (build 1803)

    Glitch happens on every map change except when entering and exiting home instances.

    Also initial display of character selection screen after login is much longer than before (approximately ten seconds compared to a couple before).

    Oh, I'm in the same boat since win10 April update and this video shows the problem perfectly (flashing to desktop upon logging in with a character and also when switching maps).

    So, what we can do with this trouble?

  • Li Xiaolu.4823Li Xiaolu.4823 Member ✭✭

    I just tested, it also happens with the old Guild Wars in Fullscreen . It is not only Guild Wars 2.

  • Gop.8713Gop.8713 Member ✭✭✭✭

    Me too, just started with the Windows April update. Pretty much the same experience as shown in holodoc's video except where they are getting a load screen with a quick flash to the desktop I'm getting a quick flash of the load screen then a longer period on the desktop, though the actual time to load the new map doesn't seem to have increased overall . . .

    Obv this isn't gamebreaking but it is kind of jarring and breaks immersion, plus I get less time with the load screen art, a lot of which is really beautiful . . .

  • Also having the problem since the windows 10 april update

  • Heather.4823Heather.4823 Member ✭✭
    edited May 9, 2018

    Guys you might wanna send a ticket. I did and they said the following. I bet they won't do anything about it until lots of people send tickets. Clearly a problem their side...

    Since the issue began only after the Windows update from April 2018, and since we've yet to see an influx of tickets or bug reports regarding this issue, I think that suggests that this is more than likely a compatibility issue from Windows or one of its programs, less so from the game

  • Nikon.3921Nikon.3921 Member ✭✭
    edited May 9, 2018

    Okay, so it doesn't fix it 100% but it does speed up the "Flicker" or "ALT+Tab Process" and so far it shows a Black Screen instead of my Desktop.

    If you Right Click on your GW2 Shortcut and go to Properties > Compatibility Tab > Change settings for all users > Check Disable Fullscreen Optimizations > Click Okay.

    I don't know if it helps with any Discord Audio issues.

  • Heather.4823Heather.4823 Member ✭✭

    @Nikon.3921 said:
    Okay, so it doesn't fix it 100% but it does speed up the "Flicker" or "ALT+Tab Process" and so far it shows a Black Screen instead of my Desktop.

    If you Right Click on your GW2 Shortcut and go to Properties > Compatibility Tab > Change settings for all users > Check Disable Fullscreen Optimizations > Click Okay.

    I don't know if it helps with any Discord Audio issues.

    Didn't do a thing for me

  • AnClar.1304AnClar.1304 Member ✭✭

    @Heather.4823 said:
    Guys you might wanna send a ticket. I did and they said the following. I bet they won't do anything about it until lots of people send tickets. Clearly a problem their side...

    Since the issue began only after the Windows update from April 2018, and since we've yet to see an influx of tickets or bug reports regarding this issue, I think that suggests that this is more than likely a compatibility issue from Windows or one of its programs, less so from the game

    I sent a ticket in a couple of days ago...No response as of yet.

  • GreyWolf.8670GreyWolf.8670 Member ✭✭✭

    It's the game popping out of DirectX exclusive mode during loading screens. I haven't had it happen with other games that use exclusive for full screen so I suspect it's something changed in the game client. It seems like it started happening around the beginning of April maybe?

  • Heather.4823Heather.4823 Member ✭✭

    @AnClar.1304 said:

    @Heather.4823 said:
    Guys you might wanna send a ticket. I did and they said the following. I bet they won't do anything about it until lots of people send tickets. Clearly a problem their side...

    Since the issue began only after the Windows update from April 2018, and since we've yet to see an influx of tickets or bug reports regarding this issue, I think that suggests that this is more than likely a compatibility issue from Windows or one of its programs, less so from the game

    I sent a ticket in a couple of days ago...No response as of yet.

    Took them ages to reply to me but hopefully the more people to send a ticket will help. :+1:

    They asked me to send a log but as I said to them it is pointless for one person to do it, they should be asking all affected to do it...

  • edited May 9, 2018

    Hey folks,

    Even while the CS Team is super busy, we would like to ask you to submit a ticket to them, so that they can gather more information and help you out, too! You should use "technical support" as the reason or the "bucket" for your ticket, to best assign it.

    They may well ask you to send in a report or a log, and that would be very helpful because it helps identify common issues and parse those that are distinctive to separate individuals and then provide assistance in either area, as they are able to.

    Thanks so much!

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Braile.3894Braile.3894 Member ✭✭

    Also got this error today after the windows creator update april 2018 update.
    Redownloading Gw2 again right now and see if its still there after reinstall.

  • smsarasin.3468smsarasin.3468 Member ✭✭

    I want to throw my name in the "me too" list... Ever since the Windows update to 1803, GW2 will drop to desktop on any map loading screens. Game plays fine other than that, but it's like clockwork on any loading screens, drops to desktop for 10 seconds or so, then back to the game.

  • Braile.3894Braile.3894 Member ✭✭

    Reinstalling Gw2 dident help, created a ticket for this.

  • Nikon.3921Nikon.3921 Member ✭✭

    @smsarasin.3468 said:
    I want to throw my name in the "me too" list... Ever since the Windows update to 1803, GW2 will drop to desktop on any map loading screens. Game plays fine other than that, but it's like clockwork on any loading screens, drops to desktop for 10 seconds or so, then back to the game.

    @Heather.4823 said:

    @Nikon.3921 said:
    Okay, so it doesn't fix it 100% but it does speed up the "Flicker" or "ALT+Tab Process" and so far it shows a Black Screen instead of my Desktop.

    If you Right Click on your GW2 Shortcut and go to Properties > Compatibility Tab > Change settings for all users > Check Disable Fullscreen Optimizations > Click Okay.

    I don't know if it helps with any Discord Audio issues.

    Didn't do a thing for me

    Shucks. What's funny, is it's actually not doing the ALT+Tab or the Black flicker screen anymore... it's acting normal again.

  • Nikon.3921Nikon.3921 Member ✭✭
    edited May 9, 2018

    I pretty sure I found the issue. I finally had a chance to check out some of the new features to the April Update and customize what I do and don't want running. And I remember coming across the Focus Assist that still had one option set to ON And it's "When I'm playing a game" I turned it OFF that and didn't think twice about it, until just now. I just turned it back ON and it's doing it again.

    This is for Windows 10 Version 1803

    • Start Button (you can type Focus Assist Settings and it should be there, if not follow next steps)
    • Settings (Little Gear)
    • System
    • Focus Assist
    • Turn off "When I'm playing a game"

    I'm able to reproduce the issue like clockwork every time I change the settings. You may have you reboot after, but I didn't have to.

  • AncientYs.8613AncientYs.8613 Member ✭✭

    @Nikon.3921 said:
    I pretty sure I found the issue. I finally had a chance to check out some of the new features to the April Update and customize what I do and don't want running. And I remember coming across the Focus Assist that still had one option set to ON And it's "When I'm playing a game" I turned it OFF that and didn't think twice about it, until just now. I just turned it back ON and it's doing it again.

    This is for Windows 10 Version 1803

    • Start Button (you can type Focus Assist Settings and it should be there, if not follow next steps)
    • Settings (Little Gear)
    • System
    • Focus Assist
    • Turn off "When I'm playing a game"

    I'm able to reproduce the issue like clockwork every time I change the settings. You may have you reboot after, but I didn't have to.

    Thankyou for this solution!

  • Heather.4823Heather.4823 Member ✭✭

    It’s not focus assist. Lots of us turned it off and still get it

  • @Braile.3894 said:
    Reinstalling Gw2 dident help, created a ticket for this.

    Thanks a lot for letting us know that. It helps to have this additional info.

    Gaile Gray
    Communications Manager: ArenaNet
    Fansite & Guild Relations; In-Game Events; Community Showcase Live

  • Jura.2170Jura.2170 Member ✭✭✭

    This was happening to me a lot last month. Every few seconds it would alt tab to desktop, and it also flashes every time there's a map change. Made it completely unplayable

    please make a Taimi voice mail pack
    my QoL wishes

  • Stand The Wall.6987Stand The Wall.6987 Member ✭✭✭✭

    ye seems clunk

  • Nikon.3921Nikon.3921 Member ✭✭

    @Heather.4823 said:
    It’s not focus assist. Lots of us turned it off and still get it

    Okay then, it's a totally separate issue from what I was experiencing. It's no longer doing it, unless I turn on that setting and like I mentioned... like clockwork. I'll be going then. Cheers and Goodluck all.

  • Vulcaruss.9567Vulcaruss.9567 Member ✭✭✭

    First Dev response after the change and this is what we get.... This is both Typical and Depressing...

  • AnClar.1304AnClar.1304 Member ✭✭

    @Heather.4823 said:
    It’s not focus assist. Lots of us turned it off and still get it

    Yep...turning off focus assist did not fix the issue for me, but it did change it. What it did was: with focus assist off, the flicker to desktop was a much shorter one...it still happens every time I switch zones or load in a new map, but instead of a 3-5 second drop to desktop with focus assist on, it is now a second or less with focus assist off. As of now, the only way I can totally eliminate the flicker is still by running GW2 in Windowed Fullscreen mode.

  • Braile.3894Braile.3894 Member ✭✭

    FYI: Workaround is to play Gw2 in Windowed Fullscreen.
    But i think fps are a little lower in this mode.

  • AnClar.1304AnClar.1304 Member ✭✭
    edited May 10, 2018

    Just installed the new May 9 Nvidia driver 397.64 for my GTX 970FTW card. Still have same issue...flash to desktop in Fuillscreen mode...have to run in Windowed Fullscreen to not have the drop to desktop on map load/zone change. If it is an Nvidia problem, it isn't fixed in this driver version...and the notes say that some of the changes are for compatibility with the April Windows 10 update. So issue continues...just more info for the support folks.

  • Ardenwolfe.8590Ardenwolfe.8590 Member ✭✭✭✭

    After setting my game to administrative, I haven't alt-tabbed out since. Haven't done this with another game, and I have alt-tabbed out. So, apparently, setting to administer required acceptance does help.

    No longer posting or playing.

  • AnClar.1304AnClar.1304 Member ✭✭
    edited May 10, 2018

    @Ardenwolfe.8590 said:
    After setting my game to administrative, I haven't alt-tabbed out since. Haven't done this with another game, and I have alt-tabbed out. So, apparently, setting to administer required acceptance does help.

    Interesting...If I set the GW2 client properties to "Run as Administrator", behavior changes. I don't get the drop to desktop...now, in Fullscreen mode, I get a flash to a black screen when it would go to a desktop before. So it's still not right. It's still flashing...only now it flashes to a black screen instead of the desktop. Strange that.

  • Ardenwolfe.8590Ardenwolfe.8590 Member ✭✭✭✭

    Now that's different. Have no idea about that one. . . .

    No longer posting or playing.

  • banshee.9328banshee.9328 Member ✭✭
    edited May 10, 2018

    The thing with flashing to desktop while loading between maps also happens to me after Windows April Update (1803) but there is something strange.

    Game apparently doesn't flash to desktop but to last screen seen before going Fullscreen. You can check it this way:
    1. go options->graphics->windowed fullscreen
    2. change map
    3. go windows->graphics->fullscreen
    4. change map
    From now on game won't show desktop but your game screen with options window opened remembered before changing to Fullscreen.

  • Heather.4823Heather.4823 Member ✭✭

    Running game as admin doesn’t work either

  • I'm having the same problem. Updated windows 10 last week and now the game client flashes to desktop whenever a map loads. It's like somewhere in the background alt-tab is happening and changing the windows focus. After the map loads I'm automatically taken from my desktop back to the game in progress, and everything works fine. I've tried several of the work-arounds listed on the forum and none seem to make any difference.

  • Malediktus.9250Malediktus.9250 Member ✭✭✭✭

    Windows Updates always cause more trouble than they are worse, only do them if you absolutely have to.

  • Lithril Ashwalker.6230Lithril Ashwalker.6230 Member ✭✭✭
    edited May 10, 2018

    it appears that even though skill 4 while kneeled may be a smoke field, it doesnt count projectile finishers and will not shoot blinding shot...but you can blast it with deaths retreat to go invis...nor does it blind enemies coming close...makes NO sense at all. Aslo PLEASE FIX Shadow Trap! it could help deadeye ALOT!

  • Vyrulisse.1246Vyrulisse.1246 Member ✭✭✭
    edited May 10, 2018

    @banshee.9328 said:
    The thing with flashing to desktop while loading between maps also happens to me after Windows April Update (1803) but there is something strange.

    Game apparently doesn't flash to desktop but to last screen seen before going Fullscreen. You can check it this way:
    1. go options->graphics->windowed fullscreen
    2. change map
    3. go windows->graphics->fullscreen
    4. change map
    From now on game won't show desktop but your game screen with options window opened remembered before changing to Fullscreen.

    Can confirm it started happening to me as well after the Windows April Update. I turned all the Focus Assist stuff off as well so it isn't that.

  • AnClar.1304AnClar.1304 Member ✭✭

    @Malediktus.9250 said:
    Windows Updates always cause more trouble than they are worse, only do them if you absolutely have to.

    No longer an option without disabling services in W10. Microsoft now forces users to update.

  • Don't have the problem that the game alt-tabs on it's own, but i get windows desktops in loading screens.

    Seems like going borderless fullscreen works.

  • Martimus.6027Martimus.6027 Member ✭✭✭

    I was having this issue, and then I updated my graphics card drivers. I use a 980ti and downloaded the most recent drivers and haven't had the issue since. I hope people get this resolved.

    I may not be what you want, baby, but I am most certainly what you need.

  • AnClar.1304AnClar.1304 Member ✭✭

    OK...on a totally separate computer...Asus ROG Strix GL503VMF laptop w/built-in Nvidia GTX1060...was running GW2 perfectly in Fullscreen mode...applied April W10 update...now have the exact same flash to desktop in Fullscreen mode as I do on my desktop rig. Just more info to hopefully help support...only change to environment was to apply W10 April update to cause the problem.

  • Same issue here. Running the game as administrator and turning off the new Windows-Fokus-assistant was able to reduce the duration the "alt-tabbing" (similar to duration in the video above).
    For me this started after the new Windows 10 update. I have a 1070 graphics-card and just installed the newest drivers. Right now im reinstalling gw2, but after a first try the "alt-tabbing" is still there. As soon as the game is installed completely i will write an ingame ticket.

  • Malediktus.9250Malediktus.9250 Member ✭✭✭✭

    @AnClar.1304 said:

    @Malediktus.9250 said:
    Windows Updates always cause more trouble than they are worse, only do them if you absolutely have to.

    No longer an option without disabling services in W10. Microsoft now forces users to update.

    True, or use enterprise/education version.

  • Trinnitty.8256Trinnitty.8256 Member ✭✭✭
    edited May 10, 2018

    I been getting this problem now since april windows 10 update pack. Pretty much as described here. Changing maps causes longer load with the flash of desktop. I used to load into maps like fractals and be first. Now i'm delayed a bit.