Jump to content
  • Sign Up

[Bug] Storm Tracking -- Cannot make jumps at floaty end part with the space background [Merged]

Recommended Posts

On 3/1/2023 at 12:00 PM, Joats.4635 said:

Yep, Same. Also, pretty sure the first time you're supposed to protect Blish in this mission is bugged too, at least for me no branded would come. Just sat there for like 2mins waiting for the progress bar to fill peacefully 😆 not complainong tho, at least that didn't affect mission progress...

I had the same thing happen. It is annoying I came back to GW2 and I didn't not expect so many bugs... I had to do the priestess killing quest 6 times before I could interact with her in the end or it would just disconnect me from the server and now this literally 20 min later. Hope they will fix it soon.

  • Like 1
Link to comment
Share on other sites

+1 03/05/2023 - Confirmed exactly same issue.  No Blish defense, no low grav.

I get what everyone is saying about it NOW being a weekend and all...... BUT...... the issue was known and not fixed BEFORE the weekend began.  A problem that can likely be solved in a 5 minute hotfix.  This forum clearly shows players beginning to have the issues and begging for them to be fixed clear back IMMEDIATELY after last patch.  I mean, if the developers ever took time to read the messages from their community; silly me right?  Or wait, I'm getting ahead of myself.... Arenanet doesn't really have a Community Director do they?


Edited by Poltergyst.9827
  • Like 2
Link to comment
Share on other sites

I submitted this issue and the recommendation from support to use a gryphon or skyscale as mentioned in the wiki. I haven't progressed in the game enough to have those mounts unfortunately. Otherwise the suggestion was to submit the issue as a bug in game. Appreciate the quick response from support on a weekend, even though they couldn't help with the issue.


I would really like to finish the story in order, so hopefully this will be fixed soon.

Edited by fyve.3401
  • Like 2
Link to comment
Share on other sites

Thanks to the instructions from Harrow.4862 I was able to do it with a griffon.


Here's the video footage, which may be helpful: 


Requires the high vault mastery for springer and aerial finesse mastery for griffon. I also use bond of faith; I think it's possible to succeed without this, but it really helps.


Still, such a workaround should only be a temporary necessity, and is still not feasible for many players due to requiring a griffon as well as several masteries.


That a bug like this is not fixed after almost a week is surprising, but could be excused given certain circumstances; the fact that no one from ArenaNet has even acknowledged that this bug is treated as a high priority and that they are looking for a fix, is quite frankly inexcusable.

Edited by woucka.1986
remark concerning bond of faith
  • Like 3
  • Thanks 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...