Do people always have a bug when doing a story mission? — Guild Wars 2 Forums

Do people always have a bug when doing a story mission?

It doesn't seem to fail, any big story I do something bugs and I have to go back and replay the same 20-30 over and over til the bug doesn't happen. Is this a common thing or just me? I love the story beat but I will say after an hour and a half of doing the same one 3 time because the boss falls through the floor, or a cinematic locks up, I don't care anymore to do it.

Comments

  • Jayden Reese.9542Jayden Reese.9542 Member ✭✭✭✭

    Nope very rarely. I know nothing about the falling thru floor but if it's freezing clean the dust out from fans / graphic card helped that issue when i had it

  • Miss Lana.5276Miss Lana.5276 Member ✭✭✭

    Depends on the mission. There are some instances with well-documented bugs (Tower Down is a notorious instance that is seemingly abandoned), and others where there are no issues at all. If you're having a problem with a specific instance might I suggest using the search function with the instance name.

    Disagreement =/= "negativity"
    Criticism =/= "hate"

  • Yes, in some missions.
    But all different bugs.

    For instance when doing the hylek bit.
    If you select to go in procession instead of the tournament, the hylek occasionally get stuck if you don't wipe out every single zombie, that occasionally don't spawn or get stuck somewhere you can't see.

    Also in the same mission, I've seen uninvited players in there for some strange reason. Especially at the top, by the cannon HP.

    A few of the later missions in Orr too.
    If you skip cinematics too many times, missions get stuck.
    On the other hand, a few repeat part of the cinematic, like the one with the charr tanks escort in malcor leap.

  • I have been working on path of fire explore glint's lair for 2 days now, have completed the boss 7 times and each time I get flipped back to the log in screen with this code: =7:11:3:191:101 getting well fed up.

  • You can try a VPN that takes a different route to that maps IP address.
    You can try minimizing all cut-scenes.
    You can try continuously moving/spamming a skill.
    You can try any or all other workarounds found in the 'official' Dev-posted thread, "Storyline Disconnections".

    Good luck.

  • edited January 6, 2020

    Bugs happen more frequently than they are reported. I just rolled with them until they fixed it self. I would like to play a flawless game. But as it seems, normal is flawed and we must report everything to get these fixed.

  • Poormany.4507Poormany.4507 Member ✭✭✭

    Cinematic disconnects have been very frequent for me during story missions (most often at the end) for the past ~2 years, which seem to be on Anet's end as all other aspects of the game work fine for me with minimal lag/DCs and I had no problem with cinematics until around when HoT/LWS3 came out. There are various workarounds, such as those posted above, but there's no definite player based solution to this problem atm.

  • Aaralyna.3104Aaralyna.3104 Member ✭✭✭✭

    @Poormany.4507 said:
    Cinematic disconnects have been very frequent for me during story missions (most often at the end) for the past ~2 years, which seem to be on Anet's end as all other aspects of the game work fine for me with minimal lag/DCs and I had no problem with cinematics until around when HoT/LWS3 came out. There are various workarounds, such as those posted above, but there's no definite player based solution to this problem atm.

    Just chiming in to say that at this time the minimum game specs went up as well, so it may be caused by that which would be your pc.
    https://help.guildwars2.com/hc/en-us/articles/201862958-Minimum-System-Requirements

    So it may actually improve if you lower your graphics.

    One cannot rule out all bugs but I never had a story disconnect on me (excl big patch day where theres too many players attempting to enter the same thing and not all big bugs are taken away yet with a hotfix). Have no lag/dceds either but I do get that message of login server connection lost pop last week (without getting disconnected). But that last, I think something is wrong with login servers as many also report downloads hanging as of late.