Jump to content
  • Sign Up

Cannot log in - stuck at loading screen [Merged]

Recommended Posts

2 minutes ago, Parasite.5389 said:

I just defeated Balthazaar, or however its spelled, then none of my skills worked, I could change characters, but now, nothing. Says network issue. Im using the same computer on the internet to type this. Now it's telling me account issue. LOL!

Edited by Vile.4387
Link to comment
Share on other sites

Just now, Errerprone.7035 said:



Can see the characters, time-out when launching zone.

   Same here. 😞 And the weird thing is, all day yesterday I was attempting to buy some gems off the Black Lion Trading Post, and not only were all the options "reddened" out, when I tried to by them it just gave me a circle of death loop as well. And upon writing a ticket about it last night, I got a reply saying to contact my Steam account. Which seems very weird to me as this was a in game issue, not an account one, and as everything else game wise was working just fine. So what now?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...