Impossible to log-in (Unspecified Error) - Page 2 — Guild Wars 2 Forums

Impossible to log-in (Unspecified Error)

2>

Comments

  • Luthan.5236Luthan.5236 Member ✭✭✭

    Well ... surprise surprise. After logging in I tried to buy gems again (which I had trouble before because of errors) - and it worked. Maybe they fixed something at the login server that caused problems for some people buying gems. (Since the login server is mentioned at the help/knowledebase as possible problem when buying gems.)

  • Bloodstealer.5978Bloodstealer.5978 Member ✭✭✭✭

    @Naxos.2503 said:

    @Bloodstealer.5978 said:
    strangely enough Guild Bank is now also working....

    Aww come on D: that's unfair, I've been waiting for a while to store precious guild mats, and now that it's fixed, the server's down T.T

    Nah they are back up again.. at least I am in from UK

    Life is what YOU make it... NOT what others tell you!

©2010–2018 ArenaNet, LLC. All rights reserved. Guild Wars, Guild Wars 2, Heart of Thorns, Guild Wars 2: Path of Fire, ArenaNet, NCSOFT, the Interlocking NC Logo, and all associated logos and designs are trademarks or registered trademarks of NCSOFT Corporation. All other trademarks are the property of their respective owners.