Jump to content
  • Sign Up

Recommended Posts

There are several things I've noticed since running around both populated maps and unpopulated maps. The framerate no longer spikes or dip as drastically, it's more stable and consistent. And while it didn't automatically make my machine jump in FPS, that's fine. It consistently stays higher when it is instead of stuttering or dipping seemingly randomly. 

Another very good thing I've noticed is that what used to 30+ seconds to load into lions arch? Now takes a couple seconds. It's amazing how the rendering times have changed. I'm going to be running around the PoF maps as well, since those are where my FPS has dipped the most when playing previously. 

Link to post
Share on other sites
  • Replies 95
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It doesn't matter. I run eso at 80+fps. I am not going to waste time troubleshooting a 9 year old game.

I love the FPS boost! 🥰 But even more so, I love how ReShade now no longer gives me those tiny hiccups during fast movements when I use FakeHDR. 👍 Can we please keep the beta option until the fin

this beta dx11 should run for as long as it can,  and the dev can do bugfix  along the way as more feedback will be provided by the players.

47 minutes ago, Ecto.2739 said:

It works fine.  set reshade or gshade for DX9.  Copy the d3d9.dll (or gshade64.dll) to bin 64 and make sure its named d3d9.dll.  When it comes up, on the far right of the bar it will say D3D11...

OK I might try that and see what happens thanks 😁

 

 

 

 

Link to post
Share on other sites
2 hours ago, Eulefant.9624 said:

So I wait till they make a mainstream version, I don't think they expect full playerbase to dive into registry and cache files 🙂

The GW2 cache has nothing to do with the Windows Registry. Also, nothing that I suggested requires anyone touching the Windows Rgistry.

1 hour ago, Eulefant.9624 said:

Remove local.dat  ( use explorer and copy paste this in quick search:  %appdata%/Guild Wars 2/ )

I can log in again, this time I leave DX11 unchecked and leave to desktop

Can log in without crash

So one of my suggestions worked after all. 😉

  

14 minutes ago, aikatara.3462 said:

Deleting the Local.dat fixed it. Thanks @Ashantara.8731 for the tip. Wow, that was frightening LOL.

Glad to hear it solved the issue. 😇

Edited by Ashantara.8731
  • Like 1
Link to post
Share on other sites

I think I had a bump in framerate, but it was the feel of the camera movement that I noticed the most. I didn't realize how much the hiccups in framerate were causing me to miss landing my camera where I wanted. I would flick it and then end up needing course correct when in certain areas (Lion's Arch, Lily of Elon.) I'm very excited to play more soon.

Link to post
Share on other sites
4 minutes ago, Redfeather.6401 said:

I think it is smoother, but I get the same framerate as when not using the dx912pxy plugin which is unfortunate since I cannot play the game at 23fps.

Yeah, my FPS is around the same (they will probably have to continue optimizing a bit further). But, rendering takes a fraction of the time it used to, and no more random dips and stutter. 

 

Link to post
Share on other sites

I honestly can't believe we were told (by ANet!) that this probably wouldn't improve the performance of the game client, or at least in any meaningful or noticable way. 

 

Because the game runs so smoothly with this DX11 enabled. Wish you guys got on this sooner. 

 

Keep it up!

  • Like 2
Link to post
Share on other sites
5 minutes ago, Redfeather.6401 said:

I finally got dx11 to stay enabled

Did you follow the suggestions posted to get it to work?

5 minutes ago, Redfeather.6401 said:

but the fps is lower than dx912pxy plugin so I will probably not use dx11 anymore.

Well, eventually you won't be able to use dx912pxy anymore, so it's probably best to try and get the game to run properly now. If you did not follow my advice already, it is possible that old files are causing the issue, in which case I recommend you do as suggested and delete the Local.dat and the GW2 caches.

Edited by Ashantara.8731
  • Like 1
Link to post
Share on other sites

@ people encountering input lag:

In the known issues ANet says that the DX11 mode is limited to 60 Hz currently. If you add VSync to that, then you get a huge input lag - but limiting the game to 60 Hz + VSync in the DX9 mode results in the same huge input lag.

I play at a limited 60 fps (via RTSS) in FreeSync Mode and the input lag did not change at all after enabling DX11 - and I am extremely sensitive to that!

Regarding the crashes: most of these are most likely results of conflicts with the existing game's cache files or addons like D912PXY or DXVK. Before I enabled DX11, I deleted everything the game put on my PC except the container file (.dat) and the executable (.exe), then started the game, enabled DX11, restarted and it runs 100% stable since then for hours and without any glitches.

Win11 x64 (22000.184), AMD Driver (21.9.2)

Edited by KrHome.1920
  • Like 1
Link to post
Share on other sites
2 minutes ago, KrHome.1920 said:

@ people encountering input lag:

In  the known issues ANet says that the DX11 mode is limited to 60 Hz currently. If you add VSync to that, then you get a huge input lag

Hmm, weird... I can't confirm that. I am running the game just fine @119 Hz as well as @143 Hz. I also have VSync activated, but with the proper settings in my nVidia Control Panel, namely "Triple buffering: On" and "Vertical sync: Use the 3D application setting."

  • Like 1
Link to post
Share on other sites
14 minutes ago, Ashantara.8731 said:

Hmm, weird... I can't confirm that. I am running the game just fine @119 Hz as well as @143 Hz. I also have VSync activated, but with the proper settings in my nVidia Control Panel, namely "Triple buffering: On" and "Vertical sync: Use the 3D application setting."

OK I tested it... 

When I disable RTSS (the 60 fps frame limiter), then the game locks to 67 fps no matter which quality settings I chose. My GPU can render that game constantly above 100 fps at max settings at my monitor's native resolution, but even at low settings it's 67. So there is clearly an fps lock. I guess this is what ANet meant.

Settings in the driver: all "application controlled", which means I don't override anything ingame with a driver setting.

edit: That lock is not present in "Window Mode".

Edited by KrHome.1920
Link to post
Share on other sites

Where I notice it the most is in Mistlock Sanctuary. Whenever I first login to a character in that area, and do a 360 camera rotation towards the teleporter in the middle, there are big stutters. When I would install and use that dxsomething912somethingsomething (?) addon, it would remove that. I cleaned all my addons out, reloaded the mount and novelty wheel UI only, and  enabled this DX11, and it works like the dxsomethingsomething - no stuttering when I do that rotation. Seem to load into some places quicker too. 

Link to post
Share on other sites
1 minute ago, notebene.3190 said:

I cleaned all my addons out, reloaded the mount and novelty wheel UI only, and  enabled this DX11, and it works like the dxsomethingsomething - no stuttering when I do that rotation. Seem to load into some places quicker too. 

It's always wisest to first clean out all add-ons (and clear the game's cache folders*), then launch the game and activate DX11, restart the game, close it again, then re-install any add-ons you know will work under DX11 (!).

*) and delete the Local.dat if you want to be sure to remove anything from the old installation that could interfere with the new game version

Link to post
Share on other sites
Just now, vinterberg.2783 said:

Well.. I run windowed fullscreen, and that makes GW2 run with 2560x1440 144 Hz FreeSync just like my desktop. So......

FPS and Hertz are still not the same thing. One describes how many frames are rendered per second by your graphics card, the other how often your screen refreshes per minute.

Link to post
Share on other sites
5 minutes ago, Redfeather.6401 said:

It doesn't matter. I run eso at 80+fps. I am not going to waste time troubleshooting a 9 year old game.

If you had add-ons installed, you need to make sure they have been properly uninstalled. When the engine changes, it can't hurt to delete the Local.dat and the game's caches - that only takes 30 seconds, which is hardly "wasting time."

4 minutes ago, vinterberg.2783 said:

I know that mate, but still... I run in windowed fullscreen 2560x1440 @ 144 Hz, so that makes GW2 run in 144  Hz refresh rate.
And therefore, if GW2 can push 144 fps, they will all be displayed.

Not rocket science. Really... C'mon..

I think you are misinterpreting the connection between frames produced and images generated.

Edited by Ashantara.8731
  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...